Soap problem with loading web services in libraries uipath

Hello ,
I need your help,
I need to make a SOAP call on UIPATH and for this reason I read this Loading Web Services in Libraries, I followed all the steps but I have some problems. After inserting the WSDL like the guide, all the services appeared in the UIPATH activities, but when I try to use the Login activity I have the following error. (The variables here are fake but I usually write real values). Here are three tests.

First of all in the activity Login I create two variables, request and response( view proprieties on the right). I use request to call the input of Login for insert company, pw and other, but when I run the code, it gives me the following error “ Multiple Assign: Can’t assign ‘company’ to request.aziendaName ”.
Request and response variables are LoginRequest type and LoginResponse type, as you can see in the picture.

And the variables with request., like request.aziendaName, are a string type.
I created the variables with the values and I insert the variables in the multiple assign activity but I have same error.

I don’t use Multiple Assign activity but single assign activity and the error changes,“ Assign Cannot create an L-value from the given expression with property ‘aziendaName’ because the target object is null. ” .

I have used the HTTP Request and it works but I would like to make this activity.
Do you have any suggestions on how to obtain a response using this activity?

Thank you.

@hdeg May be it is too late but came across this post today and it gave me a direction to approach. So, for your issue, the reason why you are getting errors in your tests is you have not initialized the request variable. It is empty. You can just put an assign activity and then request=new LoginRequest. This will give you access to all the properties and methods associated with it.