"SMTP Mail" fails on one computer and works on another

Hello
I have two computers (development and production), they are on the same network with the same configurations, I use the same version of uipath and mail, because the mail fails on the production PC and it works in development, last week it worked. Any ideas?

Uipath Study 2021.10.5
windows 10

image

Check with your email administrators. Usually SMTP is secured so only certain computers can connect to it. Your production system/account may have lost access for some reason.

Hello
I have been checking with the administrator and the firewall rules are fine and are the same for both PCs. In the mail server we have noticed the difference between one equipment and another since it gave a timeout and the other one worked fine. I have modified the version of the mail, restarted computers, deleted and added the smtp send but nothing.
I have the feeling that it is a problem with the mail activity on that computer.

It can’t be a problem with the mail activity on that server. It’s the same activity from the same package.

It sounds like a connection issue. They can manually test SMTP connections from that server to troubleshoot.

Hello @postwick
I have put a “Try” for when it fails send by outlook and it works correctly, so I understand that the connections are fine. Do you know any SMTP package to perform another test?

You said “since it gave a timeout and the other one worked fine” - the timeout indicates the connection is not working. And putting a Try/Catch around it just makes it so the automation doesn’t fault when the email send fails. It still fails.

Outlook and SMTP are two different things with different connections and different security.

Hello.
I was doing tests, I have restarted the computer and now it works (I have had more than 5 restarts today and it did not work), I am not convinced of the solution, because if it happens again I will lose a lot of time and I will not know how to solve it, I was preparing a tracert so that You would see if it had a connection to the server.
the tests have been before the restart


Captura de pantalla 2022-03-21 a las 22.43.36
Captura de pantalla 2022-03-21 a las 22.50.17

@postwick very very thanks.

@postwick
and now it fails again, the processes that were already uploaded in the orchestrator if the smtp sending works. This is crazy.

Hi @Aguirre … I could suggest you …do some test and see how long is taking to connect to send the mail … I can see is problem of connection … in the properties you can set manually the Timeout …

Hi @carmen
I have verified that in the equipment that works for me it always takes about 13000(13sec), in the equipment that fails I have modified the time to 60000(60sec) and it fails,

ok, but seems like fails ramdomly right? that computer has a different Antivirus? or the same everything? once I got a similar problem and was the antivirus that was causing the problem.

Hello, it was the first thing I did, but it didn’t work either.
One question, if SMTP is executed from one PC and not from another, if I upload from the one that works to the Orchestrator, in which one would it be executed?

The same code is executed no matter where you run the Job. When you start the Job you select where it runs and under which account (Robot).

I have put the same project on both machines, running from uipath Studio, on one it works and on another it doesn’t, same versions of uipath and Mail.

Which means the problem isn’t with your code, your packages, the activity…it’s with the computer, network, security, etc.

@Aguirre Can you try with the lower version uipath mail activities package in the production

Hello, I have uninstalled the version with which I was working, I have installed other old ones and nothing, the same package on the other machine works.

I am beginning to suspect that something is wrong with that computer, since I have tried the same code on a third computer and it also works for me.
More tests impossible to carry out, we have opened everything in the firewall, we have observed the timeout in the mail server, I have changed versions of the packages, so I only have to format that computer and start with a clean installation to see what happens.
thanks

1 Like

Yeah, it sucks but sometimes that’s where you end up. It can be impossible to find the causes of these things sometimes. A wrong driver somewhere, a corrupted file, impossible to find. We had sudden email issues one time and stumbled onto it being a certificate on the email server that didn’t seem to have any relevance to SMTP, but it did.

Hello
I have started the migration to another computer, since I have been away from work for several days, one last question, what computer do you recommend to work with Uipath? OS, physical or virtual?
A greeting.