SMTP Error Impacting 9 Automations in Production for Critical Processes

Our IT department changed our SMTP certificate from local to public certificate last night. Now we have multiple automations failing with the attached error. IT has verified that the root certificate is there and we may need an intermediate certificate. No other systems are having the issues we are having with UiPath.

We put in an urgent ticket 5+ hours ago and haven’t rectified. Can anyone advise what we may need to do to fix this?

Any help will be greatly appreciated. We have 9 production automations impacted with 4 automated processes having to be worked by the business units and 2 having direct customer impact.

SMTP Error

UiPath Technical worked with us and our IT department yesterday afternoon to determine and rectify the root cause. I am providing additional information below in case it may help others.

It was discovered that a certificate was installed that was newer than the SMTP certificate. UiPath was pulling the newest certificate which was not configured for SMTP. This was happening even though the new certificate was not assigned to SMTP.

We installed the 1.10.4 version (latest version) of UIPath.Mail.Activities. That gave us a more robust error message telling us that there was a certificate and server name mismatch. From that, we were able determine that the smtp certificate needed to be renewed.

Our IT department renewed our SMTP so it now shows as the newest which corrected the issue.
Prior to the host certificate renewal, we changed the server name to an individual server rather than the host to provide a temporary fix.
Also, we are enhancing our automations that use the SMTP activity to obtain the Server name and the Port from assets rather than config files or parameters. That way we can make changes to 2 assets rather than multiple files and parameters providing quicker response time if needed in the future.

1 Like

Hi @lhendrix1 !
Thank you for the detailed answer: this will certainly help the others that encounter the same issue :grinning_face_with_smiling_eyes:
Would you mind marking as solved your topic with your own post ? This will help people to find first your topic :wink: