Single Value out of PDF with Get Text Activity

Hi everbody,

I try a, as I thought, simple thing:

I download email attachments and safe them in a folder - is working
The folder is observed by the file change trigger activity - is working
If a new pdf is created it is opened via click activity - is working
A single value should be extraced out of the opened pdf with get text activity- is not working

I tried the following:

  • Added wildcard * in titel
  • Substitued Titel with rowName
  • tried to re-indicate element
  • tried to repair element
  • tried to change zoom of the pdf document (100 %, 125 %, 150 %)
  • tried it with ocr text activity

I attached a screenshot from my current preferences.
Now am a little bit clueless what to do next.

It would be great if someone get me hint for that problem

Thank you :slight_smile:

Anyone can help with this?

Hi @delNaglos instead of opening the pdf and reading the value from the pdf …do like this read the pdf using read pdf text activity and then you will get entire pdf data as a string so now use string manipulation to get the required data or try with once you opened the pdf use computer vision ai activities.

1 Like

Hello @delNaglos,
try to place the Get text in an “attach Windlow” with the Pdf as indicator.

It should work fine from that.


@vmariejeanne and @kalyanDev an interesting thing:

I’ve got the whole double click, get text and message box activity within event handler because auf file change trigger activity and on top is the parallel activity.

If I built a test process without the whole stuff only with double click activity, get text activity and message box where I paste the variable as output everything works fine.

Do you have an explanation for that? Is it because of event handler?

Hi @delNaglos

Can you try using get attribute instead of get text


@AshwinS2 Got the same error message like get text activity.

Are you able to highlight the selector

Yeah I can Highlight selector and it highlights the right text in the pdf document. I switched from laptop to computer and have the same issue :smiley:

Everytime I press play to run the bot the selector of the get text or get attribute or attach window activity turns from validate (green) into validate (red).