Since 21.4 robot with "studio pro" is refusing connection with error "authentication required"

Hi,

Since 21.4, when launching Studio or directly the assistant, it fails with “Uipath Robot error message” saying Authentication required"
I do suspect a proxy config pb because with all previous version I had to update UiPath.Service.UserHost.exe.config file manually at the end with
< system.net >
< defaultProxy useDefaultCredentials=“true” />
</ system.net >
and reboot, each time a new version was auto deployed. => to get it connected.
But in new 21.4 this config file does not exist anymore. Robots are in my company behind the coporate proxy and I guess that I need to find where in new version 21.4 it is mandatory to set correct proxy mode.
Do you face the same? How do you go through your company proxy ?

2 Likes

More info on issue faced, I confirm this is proxy related. Laptop with fresh install 21.4, but at home “without coporate VPN connected”, open’s Studio OK immediately and get’s my named licence studio pro (floating) from tenant in Orchestrator cloud, at first trial.

@Lim_Leng, I’ve found your recent post on proxy issue for you too, related to last release 2021.4. Very interested in reading next step on this.

1 Like

@sebastien.raimbault yes indeed. since we are both “Junior Robot” at the time of posting this issue, I believed that we are in the same type of situation :wink:

And I too can confirmed that it is due to the “corporate VPN” of ours as well.
Let me see if i can get those UIPATH official gurus to come in and comment as well.

Hi @radutzp @loginerror

Let’s share a bit of context here. Our RPA community is loosely federated. We have a core of official RPA gurus who uses the enterprise studio and orchestrator but they are more of conservative IT administrators and prefer to sit at comfortably at version 2018.4.x. Then we have another group of RPA DIY advocates from the actual end-users who loves the cutting edge of the community version (i.e. Studio X, REF) This latter groups are the actual ones coming up with the real use-cases and prototypes for official unattended licenses.

Our corporate proxies setup is such that only approved Microsoft Windows users ID can access it. this approval process is generally transparent and if i may, most likely the same for all Microsoft eco-system.

Granted that we know the following official caveat

Proxy Services that require authentication are not supported by UiPath Robots.

But we didn’t have to key in our credential anywhere in the UIPATH studio, in fact the community is previously using “user mode” + the file proxy.config

defaultProxy useDefaultCredentials=“true”

and it worked like magic :laughing: the last known working is version 2020.10.6

If anything, can the UIPATH team bring back this working configuration? or at least show us how we can still use the Studio via proxy in “user-mode”, using the current logged users’ credential like how it was done last time?

Best Regards

Been trying to add the following xml snippets into the various config files in the community studio v2021.4.0 (UiPath.Service.UserHost.dll.config, etc)

 <system.net>
   <defaultProxy enabled="true" useDefaultCredentials="true" />
 </system.net>

Nothing seem to work now :cry:

Seem like we have to continue using the v2020.10.6 until Webproxy.useDefaultCredentials is enabled for “user-mode” again.

An update. Our team is working on a fix for this issue. It will be released in one of the future releases.

Hello,

same issue here.

Set transaction status (Successful): The remote server returned an error: (407) Proxy Authentication Required.

We use 2021.4.4 since this morning.

The documentation here shows this :

Windows Credentials Proxy Authentication
Starting with v2021.4.4, the Robot can work with proxy configurations that use Authentication via Windows Credentials. To enable this functionality, add the UIPATH_PROXY_USE_DEFAULT_CREDENTIALS system environment variable on the machine.

:grin: nice, but any environment variable needs a value.
So please tell us what are appropriate variables, so we can check if the fix is OK for us.

Kind regards
Alex

It can be anything, because the check happens to see if it exists. You can put either true or 1 if you’d like.

Where to input this variable? I mean can you please specify which file, where it is located and how does the format look like?

I do have the same issue and I am not that practiced with this kind of knowledge. Thank you!

Because there are multiple ways, see here:

In short, you can simply search your Start menu for “Environmental variables”

1 Like