Simulate type not working in Excel for office 365

Hello everyone,

I am trying to do a very simple thing: Type into activity using a string variable within Excel workbook with SimulateType property. Ideally I need to type text into a Comment window (Alt+R+C creates one), but it does not work even for a simple cell A1. What I tried and it didn’t work:

  1. checked versions, both MS Office and Studio are 64 bit
  2. tried all combinations of properties available: send text to window / click before type / empty field / simulate type
  3. simulate type does work in a Notepad
  4. Type into WORKS within my New Comment window if SelectType is NOT used. if I check the box - nothing is typed
  5. I tried adding Excel scope and attach window - no result
  6. Tried typing a string VS a string variable. no difference with Simulate type.
  7. refreshed Excel package, rebooted the machine.
  8. my file is *xlsm but did not work in a *xlsx either.
  9. without Simulate type there is no issue and I see the text being typed into my New Comment window. So it’s not the selector.
  10. text is two words, no special signs, no hotkeys

Any other ideas?

Thanks in advance,

Found a workaround: using Set to clipboard and then TypeInto [d(ctrl)]v[u(ctrl)]. I am basically simulating ‘SimulateType’ (INCEPTION) :slight_smile: