Simulate click not working in salesforce

Hi Team,

I am using click activity in salesforce, when the machine is open it is working fine, but when I am running from orchestrator without opening the virtual machine. It is not working. I tried simulate click but still not working. I have used maximize activity to maximise the browser, but not working. Can any one help me with this.


@nagini.pragna Is the bot running in teh VM or in your local?

if its running in VM, can you try opening the vm and minize it and execute once.

If you are running from local and doing automation on CM then you can to keep it open.

Thanks for the reply, the bot is running on Virtual Machine. There are other click activities also in the process, only this click activity is not working when machine is not open.

@nagini.pragna Is that button in a separate frame or other buttons also in the same page???

Also can you add some delay before to click activity as well.

Can you check Wait for ready option in the properties of activity? On the other side, Some websites don’t allow the background automation. Maybe this case occurs your problem.

It is in separate page

ok thanks. I will try that option

If it is in another page then you have toa dd that click inside the Use application/Browser scope.

Better you can record that click alone using App/Web recorder. then it will give you the click activity inside the applciation scope. You can use that in your code. It will work

1 Like

I will recommend to you to put an assertion before the click.

  1. Element Exist (Click Element)
  2. Condition . If the click Element Exist
    2.1 True - Click, please set up the property WaitforReady
    2.2 Log message

maybe with this you can have a better understand of your issue.

thanks for the reply. I will try