Simulate Click Check Not working

I have a scenario where I need to input the transaction code and search for it by clicking on button.

I use click activity by enabling simulate type in properties.

it worked fine for few transactions later it cannot click on specific button.

for work around I am using click text with send windows message which works but its slow.

Note : I am using these for sap internal web portal.

It might be that the simulate type will misbehave with some applications. Have you checked the Click activity with the send windows message option?

Yes currently using the same, working fine now.


Hi All,

I’m facing an issue with simulate click option enabled in all the click activity in the UiPath 2018.3.3 in Windows 10 OS. Please suggest a work around for this issue.


Work around for this is using type into “Enter/Space”. I have encountered some issues as well, but i already fixed it using type into’s.

If you don’t know how to collect traces, please follow the steps in this post

Is it safe to share those logs and traces on this forum or am I violating the general security rules of an enterprise?

Hi @Victor_Stanescu

I believe that for an Enterprise environment it might be safer to not post any logs on the Forum.
What you could do instead is:

  • send it in a private message to our @Forum_Staff with enough context (link to the original issue here on the Forum)

OR (even better)

  • if you have the latest Studio Community Edition, you could use the in-build report system to report the buggy behaviour and attach the trance logs as attachment :slight_smile:
    Please also mention the Forum topic in the description for maximum context.
    See this topic to learn more about that feature:
    #FeatureBlog - 19.7 - Send feedback or report bugs directly from Studio

Click Not working with simulate click=True in Uipath 22.4 version

1 Like