Shutdown robot machine at night - exitcode: 0x40010004

Hi all,
please help me with my issue:
I want my unattended robot to shutdown the machine, where it runs on, at night. Our main application is not running at night. The machine will start in the morning by BIOS-setting and get updates etc. while booting.
At the moment I try with a small xaml which is triggered in Orchestrator at 8 pm. It contains opening the windows command box and entering ‘Shutdown /s’.

Some days my job runs successfully, on other days I see an error in the job with exitcode 0x40010004.

Does anybody know how to use the shutdown-command or knows a better way to shutdown the machine?

Thank you!
Moritz

@mm1904

Try to close all open applications, folders etc., before send the opening the windows command box and entering ‘Shutdown /s’.

Check more for your reference

Hope this helps you

Thanks

1 Like
  1. Make sure to close all applications and files in a “normal” way
  2. Close the process by name and then do a normal shutdown.
  3. Force shutdown /f (it will ignore running apps and shutdown anyway). This however can give problems when the machine is starting again (safe mode warning from applications, because of unsafe shutdown).
    Edit. You could also add a time to the shutdown command: /t 5
    This will execute the command, wait 5 seconds and then shutdown. Otherwise it will shutdown instantly and your proces is in error.

So try to go for the first option.

Hi @ksrinu070184 and @jvanmarion
Thanks for Your help!
In some cases the Orchestrator startet a new job before the shutdown command came to work. So I added a ‘stop job’ for the pending job, wait some seconds and then the shutdown runs without problems!
Regards
Moritz

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.