Sharepoint package - broken after machine migration

I’ve recently switched machines. My documents and appdata have syncd however, when I load my project which use ‘Sharepoint application scope’, I get a missing package error. I have reinstalled the all the Sharepoint Packages I can find but am hitting an error.

NU1101: Unable to find package SharePointPnPCore2016. No packages exist with this id in source(s): C:\Users\callaghana\AppData\Local\UiPath\app-20.10.2.\Packages, Connect,,,, Local, Official

NU1101: Unable to find package Microsoft.SharePoint2016.CSOM. No packages exist with this id in source(s): C:\Users\callaghana\AppData\Local\UiPath\app-20.10.2.\Packages, Connect,,,, Local, Official

I belive this is the package it is referring to SharePoint Custom Activities Package - RPA Component | UiPath Marketplace. How do I resolve this?

Also there is this error: Sharepoint application scope: Could not load file or assembly ‘OfficeDevPnP.Core, Version=3.12.1908.0, Culture=neutral, PublicKeyToken=5e633289e95c321a’ or one of its dependencies. The system cannot find the file specified.


Is this checked?

Yes, those are checked

As you mentioned that there was a machine migration check if any package is offered via Go! / Official feed. Often we faced Internet Access issues / firewall blocks in our projects when happening such issues

Thank you. I’ll try there.

I downloaded the nupkg and added them to appdata..\packages and then installed them via ‘manage packages’ >local. but i have the same error.

check same for dependencies, when manually downloading:

1 Like

I don’t remember having to added dependencies separately last time so I came off my works wifi and tethered to my phone > reinstalled package > I could see that the installation pulled down the dependencies and is now working. Is there a list of firewall exceptions we need to make?

in case of the feeds can be accessed the dependend packages are fetched without any additional doing. But if machine has no access to the feeds then also the dependend packages are to fetch.

The firewall should allow to access the configured feeds (urls see dependency manager settings) and the package downloads

our firewall obviously doesn’t allow that. Do you have a link to the recommended rules to put in place?

We also get the the attached error when installing Studio while on the domain.

Niether of these issue occur when off domain but that isn’t possible for all the machines we need to run it on.

I would suggest to refer to the documentation pages e.g.

So, just do a search there

Hi - i’ve resolved the installation error using the recommended whitelisting but the installation of dependencies is still erroring while behind the firewall.restoringdep

Hi @Andrew_Callaghan, have you solved this?

I’m having this same exact issue. My governance policies only have me with the following packages: image

Hey there. I just so happened to help a colleague figure this out and we found that the sharepoint dependencies required by the Sharepoint Activity package come in from the feed. So you need to check that in the Settings in Manage Packages. Then, it should bring in those sharepoint dependencies for your project.


Hi Everyone

Can anyone help me on this above request I am facing same issue SharePoint is working on one machine when I migrated my code to different machine it is giving the same error.

Thank you in advance.


Yeah it worked…thanks for your solution…