SFTP authentication

Hi everyone,

I am attempting to connect to multiple SFTP connections with the FTP activities package. I’m using the credentials exactly as they are in a working FileZilla connection (and a different automation software) but I keep receiving errors, either:

With ftp session: No suitable authentication method found to complete authentication (publickey,keyboard-interactive).


With ftp session: No suitable authentication method found to complete authentication (public key)

I have the correct versions and dependencies installed and I’m using the same server as the original, working connections.

Any help greatly appreciated!

On a simple SFTP connection with no Private key file, I’m also getting “Permission Denied (password)” error

@loginerror this seems to be an issue that has been asked multiple times with no satisfactory solution.

Are you able to escalate please?

1 Like

The source code of the FTP package is available on our Community GitHub repository, and as such anyone can help us and implement the fix.

I marked this topic as #pr-welcome so that people passionate about coding can find this and other issues/improvement ideas easier and hopefully help us improve the package.

Thanks @loginerror

I also found this thread where Ilya has kindly packaged up the new activities.

I think the latest version has already been published :slight_smile: I think it is updated on marketplace feed though rather than the official one.

1 Like

Hey can you share the url to this package? I am facing this error with the latest FTP 2.2.0 version. I am in touch with support, and they provided a custom package which was supposed to fix this issue. It didn’t worked neither. This issue is affecting bots in production. It will be much appreciated if you can address this.

In my case, I am not using any private/public keys. Just using Hostname, server name, port and password.
Error I was getting initially with v2.2.0 was
***Error: The argument of type 'System.Boolean' cannot be used. Make sure that it is declared on an activity.***

Now after using the custom package which I received from UiPath support, I am getting this error as below:

*Error: permission denied (password)*

Hi @amithvs

Sorry for late reply. Any chance you could share a dummy project with what you would like to achieve?

If there is a bug, it should be fixed in the actual latest version rather than having to work around by trying to downgrade the package.

Naturally, please don’t share any sensitive information, but if there is a public service that you can use to reproduce this issue, it would help as well.

Hey @loginerror . Sorry for the late reply. During the time of issue UiPath support provided me with a custom SFTP package with the fix. The team confirmed it is a known issue with the SFTP package and will be resolved by next update.
I haven’t tried it after the update, hopefully it’s fixed.

1 Like

@amithvs Can you share the version you got from UiPath support?
Still doesn’t work for me with latest official version: 2.3.0

Let me check… Mind sharing your mail or something in personal message.