Setting up Google Sheet Scope and have tried other solutions on other posts but still not working


#1

Hi

I am trying to use the google sheet App. I downloaded the P12 key and put in the password. I put the P12key path name + the name of the extension in the Key path in Key path in the authentication part of my object but i’m getting the following error. I saw another post which said put the path and extension but it still isn’t working. PLEASE HELP…

Access New Client Google Sheet has thrown an exception

Source: Google sheet application scope

Message: Cannot find the requested object.

Exception Type: CryptographicException

System.Security.Cryptography.CryptographicException: Cannot find the requested object.

at System.Security.Cryptography.CryptographicException.ThrowCryptographicException(Int32 hr)
at System.Security.Cryptography.X509Certificates.X509Utils._QueryCertFileType(String fileName)
at System.Security.Cryptography.X509Certificates.X509Certificate.LoadCertificateFromFile(String fileName, Object password, X509KeyStorageFlags keyStorageFlags)
at System.Security.Cryptography.X509Certificates.X509Certificate2…ctor(String fileName, String password, X509KeyStorageFlags keyStorageFlags)
at GoogleSpreadsheet.Activities.GoogleSheetApplicationScope.Execute(NativeActivityContext context)
at System.Activities.NativeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)


#2

did you get this working?


#3

I had a similar issue but then realised I was requesting my credential Key to be a JSON when it needs to be a P12 Key.

Hope this helps someone!