Setting screen resolution and running from Orchestrator

studio

#1

Scenario: BOT is not logging in to the Virtual desktop, after setting the resolution in UiPath.settings file and running automation from orchestrator.

Steps to reproduce: set resolution and set LoginToConsole = False in UiPath.settings.

Current Behavior: not logging in to VDI.

Expected Behavior: Should login to VDI and run the automation


#2

Hello.

You could try Invoke Workflow Interactive. It simulates LoginToConsole on True and let’s you set the resolution in the parameters.

I have used it with good success.

Thanks.


#3

Hi,
I have tried this, and i am facing the same issue. when i run from Orchestrator. Are there any other settings, that i need to update.


#5

Hey @ClaytonM ,

I had similar situation and " Invoke Workflow Interactive " saved me. thank you man.


PS: the activity name is Launch Workflow Interactive.


Regards,
Husain


#6

Hi Clayton,
BOT is not logging off the VM automatically, when i use “invoke interactive workflow”. Do you know any workaround? Because, this is a high density robot and i would like the first bot to log off from the machine.

Note: If i use “invoke workflow”, it is logging off.


#7

Hi,
I’m not familiar enough of how Orchestrator and UiPath interact with VM sessions to have a good answer to this. My guess is that Orchestrator logs it in then Interactive runs like the user has the window open, therefore leaving it open in the end. I do notice that if the user id currently has an open session and is disconnected it will connect then leave it open when it is finished and just disconnect even without the Launch Interactive.

We use LogonToconsole set to false in both UiPath.settings and when Launch Interactive is used, which works for High Density.

I’m also not sure leaving open sessions should be concerned about as long as you have 16GB of RAM or more and that you are not using too many individual user ids where there are up to 20 or so.

It would probably also be useful to know if there is a workaround for this so the session is closed afterward. On the other hand, depending on your Process quality, it might be useful to see the window if an error occurred.

Thanks.


#8

Hi Clayton,
Have you followed the below steps, to setup the server settings?


#9

Yeah,
We are not running into issues, but was just replying your question. We have followed the setup guide for High Density, successfully. The reason we don’t have issues any more is because we utilize 10 Robot user ids and LogonToConsole is false in both .Settings file and Launch Interactive (when used).

So, if one of the 10 user ids have an open session after a robot is run, where it says Disconnected in Task Manager, we don’t have a problem with that at this time.

Though, it would be useful to know a way to log the user off after a process runs incase it becomes a problem in the future, and for my own knowledgebase :stuck_out_tongue:

Thanks.