Set Text 'TEXTAREA': Error HRESULT E_FAIL has been returned from a call to a COM component

I am trying to paste the text from ‘Read from text file’. I did it twice for different sequence, however 1st one worked, perfectly fine. But for the 2nd on I got this error. The flow and activities is totally the same, how can I fix it?

Hello @C_Test!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

I got same error message, but I fixed it now.

My ‘Set Text’ is surround by ‘For Each’ activity.
The default is ‘ForEach item In xxx’, where ‘item’ in box.
For some reason, I change ‘item’ to ‘file’.
Most time, it work fine, but some other process, it got error: ''Error HRESULT E_FAIL has been returned from a call to a COM component".
After I change back to ‘item’ from ‘file’, all is fine now.

Hope this can help.