Session stays open after robot finishes processing

Session stays open after robot finishes processing.

Configured the following group policy would workaround the issue.


  1. Open the ‘Group Policy Editor‘ for your server.
  2. Navigate to:

Local Computer Policy / Computer Configuration / Administrative Templates / Windows Components / Remote Desktop Services / Remote Desktop Session Host / Session Time Limits

  1. Find the key ‘Set time limit for disconnected sessions‘.
  2. By default it will have the value ‘Not configured’, change it to ‘Enabled‘.
  3. Once the setting is set to ‘Enabled’, another field will become available in the lower left half of the window. Set ‘End a disconnected session‘ to the value you prefer. In my case I have set this to 8 hours, so a disconnected user is logged off after 8 hours.

Note: Setting the ‘End a disconnected session’ time value too low, may cause your work to be lost if your network connection drops. So definitely don’t set this to ‘1 minute’ or ‘5 minutes’.