Sequences alone works fine but when the robot is executed I am facing problems (Assignment 2)

When I run create yearly report workflow, with the given parameters everything runs perfectly, same goes for upload yearly report process, I have a couple of log messages and again they print exactly what I want them to print. I initially guessed something is wrong with the out arguments I am using but even when the problematic workflows runs they can’t log the message they were logging while I run the file alone.

This is where the debug pauses the execution to tell me that the notification is not found and it can’t continue but as you can see there are 2 outputs appear empty, first one is the out_YearlyReportPath I tried to log within the process sequence and the second empty info is the log message you see as the first activity in the following screenshot

This is the process workflow I tried to log the yearly report path to see if the argument holds the string or not.

And here is my supposed logs that doesn’t even log an empty info when the robot runs.

Last ss I promise. This is the way create yearly report reacts when I run the file alone with default values. There is an abundance of log messages here but I just wanted to see if there is a faulty path the execution takes and it appears not. In comparison to the first screenshot you can also see that only the month is getting logged.

I don’t read the entire post @Ruhat_Sengul., sorry for that, but I guess you need to pass that get text activity within the attach browser

I noticed that I don’t have a catch phrase of my problem :smiley: here we go, “Run file” on every sequence makes the system work, but “Run” fails.

If you are referring to the last screenshot, that whole sequence works perfectly fine when I run it, my guess was that I had some problems about the sequences in between those big parts that does most of the job but no luck so far, I will try what you have suggested though, surround every aspect that interacts with the system with attach browser. In the meantime if you can think of anything else, lemme know and I’ll give your next idea a shot too.

I don’t saw the second screenshot even :smiley: as I found the error in first screenshot itself @Ruhat_Sengul
For that error, I gave you the idea of using attach browser. Have you tried that :slight_smile:

1 Like

I’ll be back home and give it a shot in an hour or so. But the main problem is that I can’t get the full path at all. It doesnt type into anything, doesn’t log that path, I did something wrong that prevents arguments giving their respective values. Before I went out I double checked with the walkthrough doc, everything seems alligned. Will get back to you about the attach browser

I have tried what you said and no luck :confused: Is there any chance you can read the whole post whenever you got the time for it? I know it is a little bit long but at least it explains the problem I am facing thoroughly and might give you enough information to point me in the right direction

wnd app=‘iexplore.exe’ cls=’#32770’ title=‘Message from webpage’
ctrl name=‘Report was uploaded - confirmation id is*’ role=‘text’

try this selector for that activity. this is the one i constructed that can identify in both situations

1 Like

I have changed the selector as you specified but the execution does not come to that selector. The current problem is not about the selector but changing it to something that works for sure is great. Its something that happens before it gets to that activity. the yearly report that is being created can not pass its path to the upload yearly report sequence therefore the type into activity shoots blanks.

Also another problem I encounter when I “Run” instead of “Run File” is that “ACME System 1 - Reports - Download Monthly Report” page says “No report found for this vendor / month / year that you have specified.”

When I stop the execution and try it myself it keeps saying that but once after I copy the vendor TaxID, refresh the page, paste it afterwards and select that same year and month it gives me the monthly report. When the robot runs it can’t find any report even if there is a report.

I guess you can call this childish but I even started blaming the computer/UiPath version/ACME System and their interrelated relation for this

@MythicGold I have run a debug from start to finish, another member of the community named ercan showed me that it could be helpful and in fact it was really helpful, now I have a better understanding towards the problem and I have taken screenshots of the steps I thought was important. I am still yet to understand why it doesn’t really work but I feel one step closer to it, The screenshot I mentioned are in the link if you prefer I can post them as .jpg too
Debug-Step-Into-ss.zip (2.7 MB)

your dt_YearlyReport datatable variable is empty, check if you have

  1. initialized ur datatable
  2. you have read csv for monthly report and merge datatable to merge monthly into yearly report

How did you find out that yearly report data table is empty? I mean nothing is downloaded of course it is empty but it is initialized. Something to add about the video, when I type in RO254678 it is the previous tax id that did not downloaded anything, if I don’t refresh that page it still does not download, Only after refreshing it acts as it should. Main takeaway is that the part you saw working before the debug I run was a manual input

1.I have an assign activity at the very beginning of the create yearly report workflow. it goes like this dt_YearlyReport = New DataTable
2. When I run Create Yearly Report sequence alone we can see that it downloads and reads the monthly csv and then appends to the yearly csv, its just a split second but you can see it happening if you can pause the video at the right moment.

The problem is fixed by closely examining the execution with the debug tool and using only step into in order to have full grasp on the way it is being executed.

The solve for me was the TaxID variable, when I fetched the tax id from the work item details I had to put 2 spaces after “TaxID:” the substring function took a space right before the actual tax id I had to use and also kept that same space when typing into the download monthly report, I still don’t know what is the cause of this problem but the working way for me goes like this,("TaxID: ").Length instead of ("TaxID: ").Length (Forum puts only one space so I can’t give the exact copy paste material but as I previously said, there should be 2 spaces)

It took 12 days to find out this typo and it is painful to go through spaces because there was nothing more that could be looked. I hope anyone who experiences this problems finds this post sooner than later. Since this is a beginner question I imagine only the newcomers will gets to see this so, happy automating and welcome to the community!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.