Send Outlook Mail Message : Operation aborted (Exception from HRESULT: 0x80004004 (E_ABORT))


Trying to use Microsoft outlook activities( Get and Send).
Current Behavior:
While sending the outlook mail, thrown below error:
Send Outlook Mail Message : Operation aborted (Exception from HRESULT: 0x80004004 (E_ABORT))

Studio Version : 2018.1.2 Community Edition
Mail Package Version : 1.2.6863.29868

Please suggest any changes or information from my side.

Which version of Outlook is it? Also, is it open and logged-in to your account while you are trying to run the process?

Outlook version : 2010
Every time when I run the process, I need to give login credentials.

Basically, when I open/ launch Outlook… It will ask for credentials even if I check remember credentials.

Hello, Any Update?

Hi DAishwarya,
This shouldn`t be an issue if the credentials are configured correctly in Outlook.

I`ll suggest two things to do and see if they work:

  1. Update the mail activity package to the latest version (if you`re not using that already). The reason is that the latest version contains quite alot of fixed for various bugs.
  2. Try to make sure that the Outlook Users are configured well.
    A hint for me that thats the source of your troubles is the fact that Outlook keeps asking for your credentials when its open.
    Theres a way to check in Windows how your users are configured, which is to go to : Start -> Type Credential Manager -> choose the Windows Credentials Tab, and look under credentials maked as : "MicrosoftOffice", or the something like your own Mail Server address. something like There, youll have a username and password for the users that Outlook uses to log on to our mailserver, and if these arent correct, or the right user is associated with an incorrect password, then it wont work.

Please try this and let me know what you find.

Below is the Microsoft article which has some more info on the matter. I hope this helps!

I am also facing the same issue.


1 Like

Hi @5a3kh4n

I found out that for this particular error, you need to to start Outlook by using “Open Application” or “Start Process” activity in some environments before calling “Send Outlook Mail Message” activity.

Let us know if it worked for you :slight_smile:


Thanks Maciej,

Let me check it out.

1 Like

I tried with Open application but still getting the same error. Kindly.

Hi @5a3kh4n

What is your version of Outlook app and of the Mail activity package in Studio?

I’m also getting the same error appearing with Send Outlook Mail Message (when it used to work fine). Trying with Open Application still gives the same error.

I’m using 2016 version of Outlook and the Mail activity package in Studio is v1.5.1 (UiPath Studio version is 2018.4.3).

Thank you for any help you can provide.

Hi @NNIsabelle

Could you go over these threads to see if some solutions from there work?

Each topic will have a post that is marked as a solution.

i am also facing the same problem…

1 Like

I’m too

I had the same issue. What helped me was I got a popup from outlook saying that the application is trying to send an email on my behalf and do I want to allow it. I had a simulate click on the allow button and when I unchecked the simulate box it worked

Hi @loginerror
i tried most of the instructions given in post but still the problem exist.
can you help with these?


Hi @balu.9211

Could you let us know which ways to fix this issue have you tried? :slight_smile:

Hi @loginerror

i have tried the instructions given by @Ciprian_Forcos also tryed updating my email activities not worked more over tried by updating my outlook but still facing same issue.

FYI, im using below mentioned versions



Hi All,

I too face this issue.

Please suggest the solution if some has got it.