Send Outlook email from a non-default account


#1

Scenario: Trying to send Outlook email on behalf of a non-default account

Steps to reproduce: In a new sequence, create a “Send Outlook Mail Message” event. In the “Account” property, put an email address in as instructed. If I leave this field blank, the automation successfully sends an email from my default email address. I would like to specify the email address the message is sent from, however. I am able to send email from that account normally.

Current Behavior: “Account not found” error

Expected Behavior: E-mail should send from the account specified

Studio/Robot/Orchestrator Version: Studio 2016.2.6274


Send Outlook email, one account but additional mailboxes
#2

thanks for your inquiry

  • is the outlook account setup in the outlook client?
  • is the email address typed correctly , like if it might be the case that start will capital letters, like instead of "foo.foo@test.com" use "Foo.Foo@test.com"

Also try to specify the account here in a string format, meaning "foo@test.com", I have no problem doing this, :slight_smile:



let us know if this finally works.

also take a look at this


#3

Thanks for the reply. I just found the source of the problem. Try this: Control Panel -> Mail (32-bit) -> email tab. The “name” field of the email account is what you need to use in the “Send Outlook Mail” activity, NOT necessarily your email address. That could absolutely have been documented better on the UI Path website!

To try it out, I edited the name to be “a@b.c” and then used “a@b.c” as the “account” for my “Send Outlook Mail” activity. It worked just fine. This also means, however, that delegated accounts like distribution lists cannot be accessed from the “Send Outlook Mail” activity. That’s a total bummer because that is exactly what I wanted to do in the first place.


#4

I just found the source of the problem. Try this: Control Panel -> Mail (32-bit) -> email tab. The “name” field of the email account is what you need to use in the “Send Outlook Mail” activity, NOT necessarily your email address. That could absolutely have been documented better on the UI Path website!


#5

Change your default email account. Select File > Account Settings > Account Settings. From the list of accounts on the Email tab, select the account you want to use as the default account. Select Set as Default > Close. i have a same problem i call to hotmail support and they solve my problem easily over the phone