Send fldplus in Direct Connection Terminal Session


I am using a connection to an IBM Personal Communications. I use the direct connection ( I know there is one for personal communications, but that does not work in my situation yet as the profile files are in different location then install and that is not being changed)

Connection and automating works great until I come to the part where I need to send a fldplus to confirm an amount.

I tried:

  • Send Keys with [k(add)]
  • Send keys with +
  • Attaching the function to new control key and then Send control key CTRL_F9 ( CTRL + F9 works if I use IBM manually)
  • Send hotkey CTRL + F9

Still no success I cannot commit the amount with the fldplus

Does anybody have any ideas?

Hi @kim.van.helvoirt ,

Do you mean fldplus is nothing but F+ or what shortcut key you have to use to commit the amount in the Terminal system you are using for automation.


Sorry, I need to send the numpad + sign .

I got to know from your message that you already tried enter + sign by sending via send hotkeys. Do you need to enter only + or is there any special keys involved like ctrl or shift.


Could you please try like below and let me know. thanks.


Unfortunatly same result, nothing

I did do keystroke recording on real app and that said
autECLSession.autECLPS.SendKeys “[field+]”

I also then tried to just send Keys “[field+]” but again nothing.

Yeah it is strange. may be application also play role while sending hotkeys. i will also check with my colleagues and come back to you sorry currently i am not helping much in this issue.


Thanks for thinking along.

I think it has something to do with the type of connection: that a Direct Connection does not translate the hotkeys or accepts the newly set ctrl 9.

However with the other connection types I have other issues…