Send Exchange Mail Message - Cannot send mulitple attachments using AttachmentsCollection - value cannot be null for parameter name: filename

Hi All,

Is anyone able to verify the above works as I cannot seem to get this to work.

I have tried using a variable of type ienumerable and also an array of string as shown in the above image, I’ve even tried a list.

I’ve checked the ienumerable and the array contents before sending and they both show values.

My mail package is version v1.12.3


Studio Version 2020.10.4



Just an addendum - I get the same when using “send SMTP mail message” so - which looks like maybe it’s the variable but the variable is populated OK.


Is that array of strings you are using hard-coded or output from some other activity.
Could you please share us the sample how you are using string array. Thanks.

Hi Kirankumar,

Just using Directory.Getfiles.

I’ve checked the variable has a list of entries so it’s definitely being populated, just wondering if this is a bug.

I can send a single attachment no problem but when using AttachmentsCollection it can’t seem to see what’s in the contents of the variable whether it’s an array of string or an ienumerable of string



So I came back from lunch and

Deleted this that was in the paramater details that was in the attachments collection field and it worked


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.