Seletor success but run fail

I am trying to type into or click certain website, when I use selector editor and ui explorer, the highlight of my target is good. However, when I try to run the process it shows error: Could not find the user-interface (UI) element for this action.
I have tried using seletor and fuzzy selector and the result is the same.
This scenario only happen in certain website. Is it possible that the selector fails in certain website (maybe it has some block mechanism)? How can I make my selector work on this website.
Note, it a company internal website so I can not provide a screenshot.

Hello @yctsaiiii,

I’m afraid without seeing the website or your code this will be quite hard to debug. Websites typcally block automation with Captchas but cannot block people from clicking or moving around which is essentially what the automation will be doing.

Some starting points to check;

  • Is it possible that the website has a dynamic or dated title that is being factored into the selector?
  • If possible, try to avoid using Indexes within selectors, these can change very commonly and cause issues.
  • Run the automation in debug mode, when the selector breaks it should show you the closest match to your selector.
  • Don’t be afraid to use a wildcard or two (*) as long as you only have the one website open it can be an extremely helpful tool.

Let me know how you get on!



can you pin the selectors which you using ?

Hi @Veera_Raj
I have tryed to use “Selector”, “fuzzy selector” and both.
In those 3 scenario, I am able make “Highlight” in Selector Editor select the correct item, but the debug mode runs fail.

Use click image activity , let’s try it

Hi @yctsaiiii

Welcome to uipath community

In the Click activity try to enable the Simulate click option in the properties panel.


Hi @Veera_Raj
I can click my target by using “click image” activity successfully.
The type into still not working.
Is there any activity that I can click my target by “click image” and then directly type into without selecting another target.
Thanks a lot!!

Hi @Cameron_McMahon1

The following code is the html of my target

<div class="input-group date" uipath_custom_id="2">
	<input type="text" id="startdate" style="width: 180px; min-height: 26px" data-original-title="" title="" uipath_custom_id="1">
		<span class="input-group-addon" style="padding: 2px 15px; background-color: black; cursor: pointer" uipath_custom_id="26">
			<i class="glyphicon glyphicon-th"></i>

my strict selector is

<html app='chrome.exe' title='XXX' />
<webctrl id='startdate' tag='INPUT' type='text' />

and my fuzzy seletor is

<webctrl id='startdate' tag='INPUT' type='text' aaname='' />

I try to use debug mode and set a break point on “type into” activity.
However, it just shows “Could not find the user-interface (UI) element for this action.”