Selectors in Silverlight

selector
studio
silverlight

#1

I have troubles with identifying fields in Silverlight.
Some fields got a unique selector and id, but some others the same and my robot cannot find the respective field. I have tried to specify it manually, check the options in UI Explorer, I also tried to navigate with tabs, but without success.
Can anyone advise how could I move forward and what else to try?

Thank you in advance.


#2

Hello.

Do you have the Silverlight extension installed?
image

Regards,
Aksh


#3

Yes, I installed it. But since then the recording is slower, a black window popups for a few sec or my screen goes black for a few sec.

I am trying to do some user setting changes in Skype.


#4

Hi,

Can somebody help me how can I remove the Silverlight extension? Since I have installed is even worse, my browser refreshes several times and even the app needs to be restarted.
Unfortunately did not solve my problem.

Any suggestion?

Thanks.


How to automate Silver Light Website
#5

Might be the reason silverlight extension got corrupted. you can reinstall or fix it.
check out this link

https://support.microsoft.com/en-in/help/2608523/how-to-clean-a-corrupted-silverlight-installation-and-then-reinstall-s

Regards…!!
Aksh


#6

Hi Aksh,

I reinstalled Silverlight and made some clarification in the selector. Now it works properly.

Thanks a billion for your help.

Reka


#7

Good to know :slight_smile:

Regards…!!
Aksh


#8

Hi Aksh,

I have same problem of identifying fileds in Silveright.

Machine details
Windows 10
IE 11
UiPath - Trial Version.
Done all steps as you mention but no result. Still the command window of slinject appears while identifying objects in UiExplorer.

Please help.
Regards
Niraj


#9

Hi Niraj,

My solution was the following:

The correct automationid in the selector was not set during the recording, but it was very similar to the field name.
Eg:

Field name: Dial plan policy -> Automation id: DialPlanComboBox
Field name: Voice policy -> Automation id: VoicePolicyComboBox

With the changed target my workflow worked properly.

My suggestion it would be to try to guess the automationid.

The Silverlight extension has not really helped.

Regards,
Reka


Silverlight objects are not detecting by UIPath Trial version
#10

@orosreka did you install Silverlight in this : http://www.microsoft.com/getsilverlight/get-started/install/default.aspx or did you install other .exe like Silverlight_Developper.exe ?

Regards