Selectors are not editable

Hello All,

Have a good day !

Any advise ,how i can edit the selector(i wanted to edit first line of selector i.e title )
I tried to open the selectors in UI explorer also but I’m facing same issue.


Just click on the edit selector panel and edit the title attribute


It’s because you use this inside OpenBrowser or AttachBrowser activity and top level selector is inherited from the activity.
if you need to edit this, can you try to put the activity outside OpenBrowser or AttachBrowser, and indicate the target element, then edit.



@sangeethaneelavannan1 'm unable to edit it in edit selector as well.

Hello @Yoichi I have tried this but still not able to edit it.


Did you re-indicate target element outside the container?
Can you share your workflow, if possible?


1 Like

@I_am_Praj delete the activity and create it outside the sequence and indicate the element again

I tried to indicate element outside the attached browser now I’m getting different error,however i extracted the correct info with the help of extract data table and i had used Message box to for count, then i got 0 count,but how this possible.


I have created again but did not get the correct output

You don’t edit it in this activity. Go to your Attach Browser (or Open Browser) activity and edit the selector there. This other advice about moving it out and editing it etc is wrong.

The greyed out line is inherited from the parent container (Attach Browser, Open Browser etc) and that’s where you edit it.

1 Like

@postwick yes you’re correct .I have tried this but selectors still not editable(first line- tittle one )in the attached browser.

@I_am_Praj show me the screenshot of the workflow

It has to be editable. Post a screenshot of the Attach Window properties and selector.

When ‘indicating on target screen’, in the selector window open up the ‘Window selector’ and edit there. This was the only place I could edit. The data I was trying to edit was not from an attach browser activity