SelectorNotFound error for all activities in chrome


#1

I am trying to automate an web application called eBao. Whatever activities I use, throws an exception “SelectorNotFound”. Even when I tried to generate selectors from UiExplorer and add the attributes like aaname, it shows the pop up “Changes made the Selector invalid”. I am unable to proceed because of this issue. The UiPath version I use is 2016.2.6379.

The moment I scrap the element and run my code, that exception is thrown. Even I have used Attach browser/Window and found no use. Please help!


#2

@kbk install uipath chrome Extension


#3

Bro. It’s been done already. This issue is quite unique… :frowning_face:


#4

Did u tried using internet explorer


#5

The site doesn’t work on IE. Have to use only chrome. No other browsers.


#6

Check out your DotNet Framework…


#7

Yes bro. But the issue is persisting from the beginning. Didn’t work even a single time. I tried all the possible ways like reinstalling the plugins and changing the extensions setup in the browser. Nothing worked. The .net framework is also 4.6 and above.


#8

This will happen because of DotNet Framework,.did you get a chance to remove your dotnet frame work and re install it.
That will fix lot of unknown issues. also what OS you are using. please advice.


#9

Hi @kbk ,
Can we have url and what your trying to automate (mention simple steps ).


#10

No. I didn’t reinstall my .Net Framework. OS is Windows 7.


#11

URL : https://10.11.13.50/claim/

I just need to enter the ClaimId in the ClaimID textbox. Claim Id details with multiple rows will be loaded. I have to choose the correct claim based upon my business rules and proceed. No where UiPath works in this website. I entered few steps manually and tried automating but got the same issue.


#12

Better, re install DotNet Framework. also install SDK. that will fix lot of
same issues. I got the same problem on my VM and i did the same.


#13

Thanks Kelchuri. I will try that and find. :slight_smile: