Selector not working or working randomly

I have problems with the selector , regardless of the browser (IE, Chrome, Firefox).

I did a project to create/edit a record in a CRM and I noticed this issue:

  • It happens that I record a series of actions (with the creation of a record) and it works for some times, but it doesn’t work the following day. I have to edit the selector of a specific action or I have to create again the project.
  • In a project when I edit a record, it seems that it works editing the record I used to record the project, but when I use the project for another record, it doesn’t work

These problems occur in IE, Chrome or Firefox and with all project I have recorded.
I have read that there are problems with the selector, but I didn’t understand if these problems has been solved.

This mostly happens when some values change in the web page time to time, like in every refresh… You might need to use some dynamic selectors to get it resolved

Check out these links as well…

Does it work for you?



See if the selector is having “idx” attribute, and try to make a selector without idx attribute as idx value changes with each refresh and all the aaname attributes make it dynamic using wild cards.


What I have found works well, is as @anil5 says, remove Idx.

To replace wthis type, I would advice you to use the “inspect” function in Chrome, and find attributes there instead. ng-model is one I have found works very well.

You could paste your selector in here, so I could have a look

1 Like

Hello, I tried using the wildcard “*” and it works.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.