Selector for Menu Item doesn't work for dynamic files

I am trying to download some PDF files from a website one by one using while loop. Every time it opens a new file, I want to click on the Menu Item “File” -> “Save As” -> “type into” -> “Save”.
The selector which is selecting “File” doesn’t always work.

Please help me with the property selection of the Menu file that can fix the selector even if the PDF files are different.

Menu Item ui

Please check if the title of the page is dynamic?you can remove the idx and verify selectors.
Also you can check if the same can be done using hotkeys.

@Sourav_Anand you are right. The title is different for each PDF files but I can not uncheck the title. As you can see from the attached picture, it’s not clickable.

I tried to perform the task using hotkeys but to do that I need to click on the TAB first then use the hotkey alt + F. However, the selector can’t find the tab as its color gets changed sometimes. For example it’s purple now. Sometimes it gets yellow or red.

Please suggest me something that may work.
Capture1

You can edit selectors and replace the dynamic part of the title by wildcard character *

@Sourav_Anand, These are the file links of the PDF files -> https://websitename/admin/attachment/webtable/1376_upload_0.pdf
https://websitename/admin/attachment/webtable/1374_upload_0.pdf

This appears in the Editor Section as Title -> title=‘https://websitename/admin/attachment/webtable/1376_upload*

I am trying to use a wildcard like this ->
title=‘https://websitename/admin/attachment/webtable/*

It’s not working for me. Can you please help?

Did we try SEND HOT KEY activity like using hot key like alt or tab or enter
And just keys alone been mentioned without selecting element for selector
Use n number of send hot hey activity with a key until it takes us to the field

Ya more like using only keyboard to access a files or button or menu without using mouse
That would work for sure

Cheers @sadiaafrin

@Palaniyappan Yes, I tried to use alt + F for selecting File menu but to do so I have to click on the tab first as there are two opened tabs.; One for the website and another for the PDF file that opens in a new tab. Now selectors don’t work for selecting tabs as well since the color of the tabs get changed randomly (red, purple, green, yellow)

I am really stuck here and can’t figure out what to do.

Yah did tab key works on it to navigate across
@sadiaafrin

Fine
When we try to save the pdf may I know at which tab we are in
The one with web or the one with pdf
Can I have a view on that tab button
Cheers @sadiaafrin

@Palaniyappan, no to use any hotkey it wants me to click on the tab with click activity which doesn’t work.

@Palaniyappan I have attached the view. We are in the tab with pdf and if you see the link, the title gets changed with each different file. That’s where I am getting the error.

I tried using wildcard this way -> title=‘https://websitename/admin/attachment/webtable/*’
Didn’t workCapture3

Better replace the whole title with wild card *and try once
@sadiaafrin

It’s finally working. I removed the attach window and used click activity only and also replaced the name of the title with wildcard. Thank you @Palaniyappan

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.