Selector for Internet Explorer pop up "Save As" not finding the element when running "Wait for Element Vanish"

Hi all,

I am currently automating a process which requires printing an online report to PDF, and have my automation accurately saving the first report, and closing the required tabs, before returning to the main screen and trying to find the second report, whereupon it struggles. I have removed the first report from the array, and it is able to find the second, so the report selector itself is accurate, and I feel it is due to the Save As pop up, and following pop up Progress Bar getting in the way of UiPath:
image

I have used a “Wait for element to vanish” activity for this, however I don’t think it is able to see either of the pop ups.

My selector is: / <wnd app=‘acrord32.exe’ cls=’#32770’ title=‘Save Print Output As’ /> which is selected when using UiExplorer to select it dynamically. This is contained within an “Attach Window” block.

WaitNotVisible is selected for both.

Any help would be appreciated, thanks.

For more info:

I put a log message before and after the block for the two “Wait for Element Vanish” actions, and the following was displayed in output:

image

So it works fun up until this point it would seem, and shows that the progress bar is not the issue, the Vanish “Save As” box is.

@Alex_Cross Check attached file for reference

Progess_bar.xaml (10.1 KB)

I’ve automated a similar scenario and had some trouble waiting for the print progress box to disappear below is the selector that ultimately worked for me. I’m opening them in the desktop version of acrobat reader 2017 release though.

"<wnd app='acrord32.exe' cls='#32770' title='Progress' /><wnd cls='msctls_progress32' />"

Thanks, I just tried this, still getting the following though, same as before:

How could a “Wait For” timeout?

Thanks, I tried using “Wait for Image Vanish” too, and same result, it can’t find the pop up box.

It seems this pop up is created by Adobe, within an Internet Explorer frame, which might be why UiPath is struggling?

When I change the selector to point to the Website and then the progress bar within that selector I get this:

image

So I assume the issue might lie within the “Wait For Vanish” settings/properties?

Possibly, I use the “WaitNotActive” property set to true for my use case and “WaitForReady” is set to “Complete”. Have you tried adjusting the timeout on the wait for vanish? It could be that your print takes longer than the default timeout duration (seems unlikely at 30 seconds but you never know).

@Alex_Cross default timeout is 30secs, please add a safe value to the timeOutJMS and then try.

2 Likes

I set the timer to a minute, it seems to work now, thanks guys, can’t believe it was so simple!

2 Likes