Selecting PDF Elements

@Gabriel_Tatu is there something else to set in Acrobat Reader DC?

No, that should be enough. can you try with UIExplorer first?

On some configs opening preferences (Ctrl+k) and pressing Ok “unlocks” accessibility, at least until you close it completely.
No idea why, but its worth a shot.

1 Like

Hi guys,

First, happy new year 2018 ! Thanks for your answers.

I tried the Ctrl+K trick but no improvement.

Can you try with this PDF (https://www.ge.ch/relations-travail/doc/liste_entreprises_infraction.pdf) ans tell me if you all have the same issue ?

Thanks in advance !

Ok guys I don’t know what I did exactly but it’s finaly working.

I canceled both options and enabled them again

9 Likes

@pipah this fixed the issue for me as well, finally! Thanks!

Works fine until restart of Acrobat Reader. I always have to untick -> retick the above settings after restart. I could however automate the resetting of the configuration :wink:

2 Likes

worked for me. Thanks!

Same for me. Is not a sustainable solution, unfortunately. Dissapointed with UIPath PDF extraction :frowning:

This is really bad implementation in UiPath. I’m using 2018.1v. and facing the same issue. Only workaround I found is to scroll the pdf up and down manually or using hotkeys and then you’ll be able to select individual elements in the pdf.

Hope they fix it soon.

1 Like

We are working on this but until then, you can add a sequence in your workflow to enable de Assistive technology in acrobat reader (using ctrl+k) before the actual automation inside.

Hello Gabriel!
Any update on this issue? Still not able to select a particular table using Data Scraping activity

unfortunately, not yet. but try to do the enabling of assitive technology from your workflow

I am getting the same problem.

Hi,
i am also getting the same problem here , i cant scrape a specific item in my pdf file, instead it scrape either the entire page of the pdf or the entire pdf file.

Hello,

Is there really no way of fixing this? I have the same issue. Tried to do what the answer said, and it worked only partly. Now i’m able of picking kind of a section of 2 lines instead of the whole PDF document as before. I can’t pick single words og numbers.
I also have to do the uncheck and check every time i open a PDF file.

Hello, I have the same issue, any news about this problem ?
In fact, the document is totally selected (blue overlay) but I can select text using the keyboard arrows. Selecting a sector captures the text in the sector.
Thanks
TT

I believe the workaround is to activate assistive technology per file.
Ctrl+Shift+5 will get you to the option. After doing that, you should be able to select the elements.

2 Likes

Great, it works ! In fact, it looks like a bug in the reader because the option was not set in the panel you indicate, but it is set in the other panel option. Strange.
Thanks a lot @ClaytonM
TT

i used this before read this post xD and effectivily this works