Select Item 'SPAN select2-mucd-site...': Attribute not supported by the current UiNode

A special type of web UI which need to type in some character first then select from the dropdown list. (see screenshot)

Tried with “Click Text”, “Select Multiple Items”, “Get Attribute”, but none working. Read more than 5 topics with “Attribute not supported by the current UiNode”, but none matching.

Any suggestion…

Hy @MubieSam_Lin,

Try clicking into an item and then check the selector, use the ‘Open UI Explorer’ window so UiPath will display all properties captured, hope it helps.

Please let me know if it worked, if so please like my posts and mark my answer as solution, it helps me :slight_smile:


Hi @William_Blech_Sister

What activities should I use to “click into an item”? I tried “Click Text” with “Open in UiExplorer”, but only see one option in property explorer, and got error " Click Text ‘SPAN select2-mucd-site…’: The method or operation is not implemented."

Thanks for your help

Hy @MubieSam_Lin, Try the ‘select item’, does it work?

Hi @William_Blech_Sister

No, This control does not support select item.


Another alternative is to navigate using send hotkeys, tabs and enters. Try it and let me know.

Hi @William_Blech_Sister

Do you know someone from UiPath who might be more sure with this issue?

It’s my bad, just tried out with Click > Type Into > Click, it worked.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.