Select Item on Drop down box not helping

I have a non-editable text box in a webpage with a lens button next to it. On clicking the lens a pop up window comes with a dropdown list. When I click (mouse click) the dropdown and click (mouse click) an item in it, the system immediately closed the pop-up, takes me back to the original web page and populates the selected item in the non-editable textbox.

When I tried to automate this in UiPath, I used an “on element appear” activity after clicking the lens button and used a “Select Item” activity and passed a variable that has the value to be selected. When run, the item is selected in the dropdown but nothing happens (the dropdown does not close and does not take the control to the webpage and populate the value in the non-editable textbox). What I need to do get this working.

I even tried a click activity, send hot key (tab) after that.

did you tried with 2 clicks?. first one click to drop down the list, and the other click using f2 key to get the item you want to click, or even you can search by selectors in the drop list and click the selector you desire. our use the click text activity too, this can be another solution as well.

Have you tried Type Into activity with K(enter)?
Indicate the dropdown and enter the text you want to select (Match case and spaces). + enter.
Hopefully it will work

@rachrahul2 thanks… I tried type in to and a enter in the end. The control went back to the web page and continued but the item to be selected is not passed to the edit box.

My whole project is stalled because of this! :frowning: I even did a select item and send hot key (tab)- The item is selected and highlighted but its not passing the value to the webpage.

In those scenarios find children on selectitems in combination with clicks did help

  • find children
  • calculate/fetch the selectitem that is to click
  • click expand box
  • click with the usage of the fetched selectitem

instead of element appear the combination of retry scope and element exists to a well known reliable element of the expanded box can help

And surely: if website is public share the URL with us, so we can more direct help

@ppr thanks. Sorry its not a public website that I can share with you. I have not used find children before. let me read that first.

in case of starter issues let me know. Maybe some help on demo can be given to you

@fernando_zuluaga Thanks. I tried the 2 clicks - first click for the drop down button and the second one after F2 to select the item list. But the selector from the second click is not having any value from the drop down that I can use to replace with. It rather shows the screen behind it. I think the uipath is not reading the drop down.

When I tried click text - I get the error “Click Text ‘BODY’: Text was not found”

Can you use an attach window to capture that pop up window after you click on the lens?

@bcorrea Thanks. I did attach the window. Somehow Uipath is not recognizing I am clicking an item in the dropdown rather it selects the window itself!

do you know what kind of web application is this? did you also try looking at that popup using UiExplorer to see if we can see the structure of that?

For such Analysis Open uiexplorer in Standalone Mode via UiPath ribbon - Design - uiexplorer

Here you click on the drop down Box and later manually inspect and reconfigure the selector by browsing left Side visual tree. Dont forget to right click ob element of choice and select as target element

The found selector you can Copy to the Second click activity

Hi @Devarajan_Sundaresan,

You can check whether you have the option of making a simulated (or Send Window Messages) click directly on the selection you want. That worked for me in a similar case

@cmolina what do you mean by simulated click?

oh yeah…I did try that before the click with simulate

@ppr See attached. In the UI Explorer this how the selector is for the click activity. The list values is coming in rowName. How can I make a selection out of those? The click activity is not picking up a value from the list. I think its not a list item?!

since it is a SELECT tag, you should use Select Item activity, it has to work :upside_down_face:

Perfect regardless for which option you will go do some edits:

you can make your selector more strong by:

  • using yellow marked selector additional
  • removing the red boxed part because of:
    • with adding the form tag to the selector (assumed there is only one select box with the name listitems in the form) the select is already adressed
    • the rowname makes the select too specific to e.g Karthrik…

please expand on left side (see the arrows) and give us insights to this with a second screenshot

By a first look, select item should work, 2 click approach should work, but we will know more with the second screenshot