Select item from the Windows start menu?

Hi all, I’m running an app that must be launched from the Start Menu. StartProcess or OpenApplication (or even running from a command line) won’t work.

I tried a TypeInto, clicking on the Windows Start button and entering “AppName [k(enter)]” as the text, but that doesn’t work in UIPath ,though it will if I do the steps manually. The Start menu opens, but nothing is typed in the run box. Any ideas? Thanks.

You could use a send hotkey (Windows button), type into (search string), and another send hotkey (Enter to click)

But an more reliable way would likely be to just use the “Start Process” activity to launch via command line so you don’t have to worry about any of the menu navigation/compute time on windows side of things.

1 Like

Thanks Mike. That worked (must enable SimulateType). Start Process doesn’t work with this app, unfortunately.

1 Like

Ah that’s unfortunate, glad you came to a solution though!

1 Like

Hi @cockcron _ You can do something better than that this and more reliable here are the steps:

  1. Send Hotkey Window +r
  2. A pop will appear enter the name of the process and it will open.
    Here is the screenshot attached to open internet explorer
    image

For chrome you can write chrome it will open the chrome.

Hope it will help you.

Best!!
Anmol

2 Likes