Select a value from dropdown dynamically

I’m trying to select a value from dropdown. I tried ‘Select item’ dropdown but it gives an error.
How can it be resolved?

Hi @Gopalakrishnan_K ,

This error is raised because, the element your identifying does not support the feature of dropdown. Try to use Click activity by passing values dynamically instead.


The dropdown contains many values and so I think applying click activity to select the exact value may not be applicable. Can I search for the required value in the dropdown and then set the corresponding value when found? If yes, can you share post or video for the same?

Check this out Indicated Target Not Valid UI Element for SelectItem - #9 by AndrewHall

This has happened to me mostly with dropdown with CSS libraries like Bootstrap. You have to select the element with the UI Explorer and there in the tree select the “select” of the html.


Is that field has the feature to type and find?

Yes. I can type the value and select from the dropdown or directly choose from the dropdown. Uploading the dropdown:
status value
I tried using Type into and click activities to select the value. But it’s not working for selecting different values. It is working only for selecting a specific value.Is there any other solution for the same?

Use type into activity to enter the value & use click activity to select the below option. Change the selector of click activity by enabling the aaname option & pass the value dynamically into the selector.

This post is regarding StudioX. I’m using Studio community version. Will that make any difference?

How can I enabling the aaname option & pass the value?

Have a view on this thread for similar scenario

Cheers @Gopalakrishnan_K


You can achieve this by using the Find children and Get attribute Value activities.
select the inner text and modify it.

please refer


Once identifying the element using click activity, click the three button icon and select Open UiExlporer option.

In the right side of UiExlporer screen, under Selected items section, enable the aaname and select the variable which your passing the value.


No it won’t

Yesterday It worked for me but today it shows some validation mistake for me.

Don’t know why it shows like that.
I did the ‘Find children’ and ‘get Attribute’ option to select ‘aaname’ but it selects the required option but not clicking the option in the dropdown.