Screenshot on unattended VDI

Thanks for that, Klaus. I appreciate the input.

We’re not using a version of Orchestrator that supports those settings, but they are available in the Uipath.settings file on the local robots. And we definitely went a few rounds with those early as we have some bots that do rely on those settings to accurately perform OCR, etc. So I am pretty sure we’re good there. But I appreciate that suggestion.

Hi Scott,

Sorry for resurrecting this post. I’m pretty new to UiPath and I was hoping to learn more about your setup so I can prevent any headaches in the future. When you said you were scrapping VDIs and going to an RDP solution, does that mean you swapped all of your unattended processes to Windows Server systems?

If you could give a high level overview of your setup I would appreciate the insights.

Thank you

Hi Seth. Yes, we did scrap our VDI infrastructure.
Using the Terminal Services has its own idiosyncrasies, but it has been far more reliable for us than VDI’ s were. I do not know if there have been improvements in VDI reliability since then, but we have been on Terminal Server’s since January.


Hi @Scott,

Even we are facing same issue.
We need resolution of 1920*1200. So we have configured the settings in orchestrator as follows:
Log into Console is enabled and set to No
Width: 1920
Height: 1200
But when these settings are made. Bot is not able to take screenshot, because of which save image activity is giving ‘Object reference not set to an instance of object’.

Can you please let me know how you have resolved your issue?

Hi @Akashat
Just wondering but you mean 1920x1080 right cause you put 1920x1200 which is not very standard.

I just tested a TakeScreenshot with both resolutions set and it worked with no issues:

However, I have seen the error you are talking about on occasion, where it says “Object reference not set to an instance of object”. But, it seems random and I have not identified the issue on our end.

If you could provide a sample workflow using your Take Screenshot then maybe we can rule out a problem with how you are using it, assuming you are getting the error consistently. Because I only get it ever once in a while and seems like an Environment issue and have not figured it out yet.


Hi @ClaytonM,

The same resolution we have resolution of 1920*1200 and the bot is taking screenshot when we run through studio or front end mode. But the we are getting the mentioned error while running in backend mode.

And regarding code, I cant share here due to some policies of the company. But I can provide you the steps, its just two activity code:

  1. Take Screenshot
  2. Save Image
1 Like

Do you know if the user profile being used has a logon session, where it says “Disconnected” when not in use? You can try having that user profile logged off and try again, because there could be an issue with how the user is logged in.


I’m also facing the same issue while running my code in Unattended VDI, the Screenshots which taken by the BOT is mostly black or white. Don’t know what solution we need to follow. If anyone who had faced the same issue. Can suggest some working idea which helped in this situation.


@KarthikBalaje24 do you have more info on how you are taking the screenshot? Have you tried publishing something that all it does is take the screenshot?

I know if you disconnect from the session it turns off the GUI, which could result in a black screen. But, I wonder if there is some configuration problem where your VDI sessions don’t have unattended GUI on. I’m not that familiar with VDIs though, so you might need to check with your VDI support team, depending on what the issue really is.

Thanks @ClaytonM

Yeah I’ve tried publishing a sample code which would take screenshot alone which works fine if the VDI is in attended mode but If I run the same code in unattended mode, the screenshot taken is completely black. As you’ve suggested let me check with the VDI support team to ensure the session is active though it is running in unattended manner

@UiPath Team - If available, please provide some for any handy solutions

Hi ClaytonM,

This issue is due to version mismatch between UiPath Studio & UiPath Orchestrator. I was using Studio 2019.4 & Orchestrator 2018.3 so the BOT run behaved in such ways. But after changing the orchestrator to the latest version. The screenshot black screen issue is not happened at all.

Karthik Balaje

1 Like

Hello CalytonM,

As you have mentioned your able to capture screenshots.
Wanted to know whether we should always have a interactive session open while running unattended robot from orchestrator in order to capture screenshots or unattended robot can launch interactive session by itself.
Please correct me if my understanding is wrong, I am very new to this.

I am running an unattended robot in Azure VM. The process is scheduled from orchestrator.
If I have an active remote desktop connection made from a local machine to the VM ,screenshots are captured but if I disconnect from RDP, process still is running in VM but screenshots are not captured.

I am using community unattended robot, please let know if this is a limitation as i am using a community robot.

Hi @RajaniG, you don’t need use a Launch Interactive activity or anything as long as you are on a version later than 2018. You can just edit the Robot settings in Orchestrator to have False/Off on LogonToConsole and set your resolution settings you use (default resolution will not work well, so use 1920w 1080h 32depth)

Taking screenshots should work then in unattended with disconnected RDP.

Hope that helps.


1 Like

Thanks for suggestion Clayton.
I did try all thr above mentioned methods but it did not work.
I suppose problem with my is the installation method as mentioned by loginerror in the below post

How about running on VDI mode?
In the latest orchestater version, can we still take the unattended bot activity screen shot?
What software did you all used to take the screen shot of the unattended bot?

@clementson I don’t have much experience with VDI, so I couldn’t give that good of advice. I would expect it to work the same for taking screenshots though. And, if it doesn’t, then there could be some image or installation issue with the server. We use 2018.4.3 I believe and have no issues taking screenshots in a VM. Maybe when Studio is a newer version, there is a disconnect between how the session is logged into and the UiRobot.exe / UiRobotSvc that runs on the server (but I don’t know). - it’s usually recommended to match the versions between Orchestrator and Studio in case of feature compatibility differences.