Screen Scraping not showing any Screen Scraping wizard - Classic

Hi All,

Context: I’m in the midst of doing this course

In practicing the ‘Screen Scraping’ using classic method on this this particular app (first ss), it does not return anything i.e. no screen scrap wizard is showing as opposed to the one shown in the course (second ss).
Additionally, I have the same package as the course instructor does.

Any idea how to solve this? Kinda stuck


hi @Dillon_Marius

uncheck the Modern design Experience property in project settings

Hope it Helps!

HI Dinesh!

I have indeed unchecked the modern design experience here and it still is not working.

Any other alternative solutions you might have?

Cheers

Hmm no I think it’s not appearing like earlier
You will be directly taken to design panel
I think the course has to be updated
But the thing is wizard is not appearing and it’s takes u to the studio design panel

Still u can use get full text and get visible text as a activity from activity panel

Cheers @Dillon_Marius

Hi,

downgrading UIPath.UIAutomation.Activities to v19.1.0 and try

1 Like

@Dillon_Marius
use the ocr scrapping method

Hi Palaniyappan,

Well noted. Indeed it’s possible to use ‘Get Text’ per your point and the intention of the course however is to try out the ‘Screen Scraping’ feature wherein in my case isn’t showing the Screen Scraper Wizard nor was there any output on the studio when clicking on the Application shown in the ss.

U still get the output as string type which u can utilise further
Write in a text file with WRITE TEXT FILE activity, pass this string as input and view the results there

Cheers @Dillon_Marius

Hi Dinesh,

Thanks for dropping in. I have tried your method and I believe the expected behavior is for the ‘Screen Scraper Wizard’ to show up? cmiiw.

But in my case the output looks just like this without any ‘Screen Scraper Wizard’ pop up.

The expected output that the course intends us to do is to make sure that we can get all the text and its elements, which you meant ocr scrapping method could work? (which is under recording, citrix native or is it in the Screen Scraping wizard? which in my case is not showing)

Hi Neha,

Thanks for the suggestion however the version doesn’t in the drop down list per ss seems to not go below 21.x.x

Any suggestion?

I have actually tried out @neha.upase suggestion to downgrade my version and it works…

Altho It’s still within the 21.x.x version but earlier than the version I was using earlier and it’s now working. Kinda weird. Is this normal that different versions have such different behaviors?

1 Like

Hi Palaniyappan,

That makes perfect sense logic wise. I can understand that however in my previous trial no output in the studio at all - even checked the variable and no new string variable was created nor stored.

But thanks for the suggestion nevertheless!

1 Like

Well it could be because of the selector used to identify the element or region of scope in the application
Try creating a stable selector and check for the results
@Dillon_Marius

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.