Screen resolution issue when running process in production environment

Hi @tmays

I tried your solution with no luck. When executing the powershell command i get an error saying that the video device does not support the resolution. I have tried with several resolutions, including 768x1024…

The rdp session is accessed through citrix so i think that the resolution configuration has to be changed from the server side, and i am looking into it. If anyone else have any experience with this please comment :slight_smile:

Hey @nbjerke. It was worth a try. Once you figure it out, please share your solution for others following in your footsteps. :slight_smile:

I have used Launch Interactive but when I take a screenshot while it’s running, it actually still runs at 800x600 or 1024x768

I was curious to see if the UiPath.settings resolutions would resolve this too.

There appears to be a flaw with UiPath from my perspective.

However, I have been getting Image activities to work using Launch Interactive but just the screen is smaller. So, if it’s just that stuff isn’t on the screen, can you try using PgDn or Scrolling to place items in the screen? @nbjerke

Please share if you are able to get it to show the screen in proper resolution size. On the other hand, I have gotten 100% of my processes to work regardless.


Did you ever fix this issue. I have exactly the same issue, on my production server if I connect via RDP and start the robot it works at the client resolution. If the robot runs itself I can’t get more than 1280x800 causing the application being automated to not display correctly.

I’ve tried all the UiPath setting plus registry changes on the server to try to force a resolution but with no luck. As it stands I have to manually connect and start this robot every morning which obviously isn’t a long term solution.

Did you set the desired resolution for the robot in uipath settings?

1 Like


I have not found a solution to this problem. I had to redesign my workflow to work with a 1024x768 resolution. I have tried the same as @bobpeers, changing the uipath settings and registry with no luck. I do believe that it is an issue with the citrix vm which runs windows server 2016, that has been set up with a standard resolution 1024x768. In a previous project i have managed to change the resolution by adjusting the settings file or the runtime settings in orchestrator, however that server was a local one, that we connected directly via RDP and not citrix. Do you have any experiences with this @Gabriel_Tatu?

Yes, it has no effect at all.

Thanks, unfortunately our application is unusable at 1024 x 768 :frowning: I also think this is connected to limitations on the server side. We use VMWare vCloud and it could be related to the virtual video driver not supporting higher resolutions. We are currently contacting our virtual host provider to see if they can help.

I’ll update here if I find out anything.

1 Like

To update we have fixed this issue. It was due to a lack of video memory on the virtual server so no matter what I set in UiPath.settings it would never go above 1280x800.
We now had our provider add VRAM (we could no do this ourselves through the vCloud console) and after a reboot the UiPath.settings file works and we can get a 1920 x 1080 resolution.


Thanks for the info @bobpeers :slight_smile:

How to set the scaling to 150% in the resolution, I am using windows 10 and the virtual machine is running on windows 10 too. I am using 1920*1080

I have same issue as OP. We are using vm-ware virtual machines running windows server 2016. Remote desktop resolution was never issue, resolution was 19201080 after server hosting added more gfx memory but when running unattended robot task from scheduler resolution is 1024768. I have tried all I can, changed all windows registry setting that might control default resolutions (mostly DefaultSettings.XResolution etc.), set UiPath.settings resolution to 19201080 and still somehow resolution changes to 1024768 when I close rpa_user remote desktop and let scheduler run robot.
After that when I log in with “rpa_user” desktop size “flashes” back to 1920*1080.
So any idea is this is scheduler related downsize to resolution or does Robot somehow command resolution change? How to fix this? Does vm-ware has control over non-remote desktop session resolutions (scheduler)?

Even funny is that this machine is cloned from virtual machine that after some magic had proper resolution while running robot using scheduler. Only difference should be that older machine has UiPath 2017 and this new machine has UiPath 2018.4.2.

Hi Dev, are you able to fix the issue. We are facing similar issue. Any help would be greatly appreciated.


Using VPN client robot can change proper resolution if virtual server allows but with “closed remote desktop session” unattended 2018+ robot gets only low resolution which seems to default 1024x768.

is this issue resolved? If yes, Kindly post it here. I am also doing citrix automation.

Request someone to clear the below doubts.

  1. What is the location of Uipath.settings file?("…AppData\Local\UiPath" or “C:\ProgramData\UiPath”)
  2. Process to set the screen resolution for Robot.
  3. Is there any other process to configure screen resolution for the Robot(Aim is to make the workflow execute in any machine)

Yeah I also faced the same resolution issue. Tried to change the resolution using powershell script “” but no luck. Even after PS is executed It runs the code in the default resolution 1024x768 while running in unattended mode

Hi @rameshgp43

Did u got the solution of Screen resolution setting? I want to contact you.
Is there any way to contact you?


Did you get a solution of the mentioned issue. I am also facing the same issue, when running the BOT in unattended mode it is not working while it is working in obserbvation mode.


i had a similar issue, the robot setting “login to console” can limit the screen resolution if set to true

Take into account that this setting is set both in the robot “settings” and in the “settings” file of the “server” ( The UiPath.Settings file is stored in the %ProgramData%\UiPath folder.)

Hopefully the issue is this :slight_smile:
Best regards

I faced similar issue earlier and it was resolved by following below -
– “LoginToConsole”: false - Robot Orch
– “LoginToConsole”: false, - UiPath.Setting
– Check VM/RDP hardware configurations to allow higher resolution…

1 Like