Screen Lock issue while Data Scraping

Hello,
What I am doing is!

  1. Create Bot in my pc after that I deployed into my other pc using taking TeamViewer that works good.
    Bot job is simple data scraping that’s it.
  • and the issue after some page rendering it’ll auto stopped the bot, after that if I’m closing the team viewer and reconnect that then screen is locked…and if I didn’t close the team viewer then it’ll works good but the bot didn’t work.
  • I don’t have any idea I search on the internet but did not find anything! I tried that registry windows 10 lock screen kinds of stuff but still doesn’t work please help me out

Hi
kindly run in debug mode once from studio so that we will come to know what is the problem and which activity does this
Cheers @ifenilpatel

process is like, on the site there are 180 pages and with the next button,
pages render up to 80 pages and then this happens.
Thanks @Palaniyappan

Fine
so what is the value mentioned in the property MaxNumberOfResults in the property panel of EXTRACT STRUCTURED DATATABLE activity, because that might affect here,
if it is less than the total number of records we need

Cheers @ifenilpatel

1 Like

total record is around 2K and I mention 5K.
and also set write CSV activity.
process stopped in between the Data scraping @Palaniyappan

aah mention as 2000 in that property and try once running in debug mode
Cheers @ifenilpatel

1 Like

alright! ill try. @Palaniyappan
here is my ss of bot!
Black one… process stopped over there.

awesome so what was the error message…we get
Cheers @ifenilpatel

there no error! bot has just stopped that’s it. @Palaniyappan not sure whats wrong.

yah it would be really helpful if we have the exception message
so that we can proceed from there on
Cheers @ifenilpatel

it is working now! i have changes 5K to 3.5K MaxNumberOfResults but what if there are morethen that ? @Palaniyappan

@ifenilpatel

Try the solution given in below So that when you disconnect from Team viewer the screen wont lock and bot will continue running

On the remote computer, in the Actions menu, under Lock, there is a “lock on session end” item that is checked by default. Unchecked that and it did not log out after ending the session.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.