Scheduling a back office robot using task scheduler

so this concludes scheduling => orchestrator. be it a process or a BOT ? correct ?

From orchestrator, you can schedule a process to be executed by an Unattended robot at certain triggers(daily, weekly etc)

The question is can i schedule a Back office robot using task scheduler?

You can try with the link @ddpadil provided, but it’s not a guarantee that it still works since UiPath no longer supports this feature.
Or you can test with Orchestrator Community Edition and see if it better fits your needs: https://platform.uipath.com/

When i tried to schedule the process through task scheduler then it opens my xaml file but it is not able to exceute the same

Hi @mudit,

Please try to follow the steps below:

  1. Create a .bat file like the one attached and set the parameters if necessary inside it
  2. Create a shortcut by using the Run feature inside windows
  3. Schedule it in Task Scheduler to execute this shortcut at certain moments and start your robot

Both .bat file and the Run shortcut should be at the same folder of the robot.

Run.zip (271 Bytes)

image

Copy it to your folder and change its properties like:

In task scheduler, just call it:
image

5 Likes

:clap::clap::clap::clap::clap::clap:: :+1::+1::+1::+1::+1:

1 Like

@acaciomelo The attached zip file shows up empty when extracted. Is there anyway you could send the sample .bat file to me?

Hi @atevis,

This is the content inside the .bat file.

start “” /min “C:\Program Files (x86)\UiPath Studio\UiRobot.exe” /file:"%~dp0Main.xaml" /input:"{‘StartedByTaskScheduler’:true}"

Great, thanks! So for a BOR or even a FOR, you have it run the xaml file, not the nupkg file?

The problem is the task scheduler is able to run the process when a user is logged in but it is not able to do the same when the user is not logged in. I have changed all the settings as required but it is still not working

Hi, please check this Start from command line

You have to use options /executor and /monitored with UiPath 2016.x

With UiPath 2017.x you have to use option --monitor. Here’s an example .bat file content.
START “” “C:\Program Files (x86)\UiPath Platform\UiRobot.exe” -file “C:\Users\User\Documents\UiPath\Project\Main.xaml” --monitor

You can also use this command directly in Task Scheduler without a .bat file. Just configure the schedule as Start a program, give the path to UiRobot.exe and arguments exactly as they are in the example above.

did not get your point.
here what i have done

why this is working when i am logged in and not working when i am logged of

Do you have /monitored and /executor as arguments in your schedule?
Have you given “Log on as batch job” user rights to your user account? https://technet.microsoft.com/en-us/library/cc957131.aspx

Please check the link in my previous post again and also check the links in that post.

everything is in place it is just that when the user is logged in the scheduler triggers the process and when the user is not logged in it does not.
However the task history of scheduler shows that the task was triggered but i can see that no logs were generated

What about the scheduler option “Run whether user is logged on or not”, do you have that set?

afcourse dude it is there…

{
“NuGetApiKey”: “”,
“UiPathServerUrl”: “”,
“TracingLevel”: “Information”,
“RobotKey”: “”,
“LoginToConsole”: true,
“ResolutionWidth”: 0,
“ResolutionHeight”: 0,
“ResolutionDepth”: 0,
“LowLevelTracing”: false,
“NuGetServerUrl”: “%ProgramData%\UiPath\Packages”
}