Schedules no longer executing

Hi @calahorn , can u share me how to create batch files for UIPath processes? Will Appreciate alot and many thanks.

@Alvin Here is a sample batch file. Its crude, but gets the job done. If you run it, it will run 3 of my automations, pause for 40 seconds, and run that loop 30 times. After which, it will run another automation, and check if the time is 11pm. If it is, it will stop execution, and if it isnt, it will start the whole process all over again. Hope this helps.

:begin
for /l %%G in (1,1,30) do (
START /WAIT C:\Users\myuser\AppData\Local\UiPath\app-19.2.0\UiRobot.exe -file C:\Users\myuser\Documents\UiPath\Project1\Main.xaml
START /WAIT C:\Users\myuser\AppData\Local\UiPath\app-19.2.0\UiRobot.exe -file C:\Users\myuser\Documents\UiPath\Project2\Main.xaml
START /WAIT C:\Users\myuser\AppData\Local\UiPath\app-19.2.0\UiRobot.exe -file C:\Users\myuser\Documents\UiPath\Project3\Main.xaml
timeout /t 40
)
START /WAIT C:\Users\myuser\AppData\Local\UiPath\app-19.2.0\UiRobot.exe -file C:\Users\myuser\Documents\UiPath\Project4\Main.xaml
SET hour=%time:~0,2%
IF %hour% LSS 23 (
GOTO begin
)

I’m assuming its down again as none of my jobs were executing this morning, even though they were executing last night after 6:30pm CST. I guess I’ll go back to the backup plan for now.

confirmed orchestrator community is now running scheduled jobs as of 2 minutes ago. However I engaged multiple schedules and it looks like it went back down. :frowning:

Hi @calahorn thanks alot… yes indeed… i found last Sunday all schedules are running accurately, now running random jobs again :frowning:

You guys are giving the servers a very warm hug :slight_smile: Please bear with us as the team is trying to permanently resolve the platform behaviour.

No specific ETA, as service is still running with small hiccups here and there, but we’re on it!

It’s too much love! :smiley:

EDIT: some immediate fixes were already implemented; let us know how it behaves :slight_smile:

1 Like

Schedule is still not start at correct time, it will start 3-4 hours behind.

1 Like

Hi guys,

I think it is down again. I scheduled my bot for every minute but i cant see any thing in jobs , Not even faulted or pending.

Kindly help fast that what is wrong.

1 Like

Hi everyone,

I am facing the same problem.

Regards,

Hi guys,

I have recently scheduled a robot to run at 1:00 AM UTC-6 Central America. Here is 8:25 AM UTC-6 Central America and it says that the robot will run in few minutes, which is wrong.

I appreciate your help.

@luisvrd I believe they are still experiencing issues and delays with the community orchestrator. I’ve since moved over to our corporate orchestrator, but if your company doesnt have one, perhaps running them in batch files and windows task schedules might assist until they’ve worked out the kinks with the community orchestrator. I’m sure @loginerror will let us know when things are running smoothly again.

2 Likes

Thanks @calahorn for your suggestions. Please @loginerror let us know when everything is restored.

windows task scheduler ? I thought it’s not supported on CE… any links ?

Any news on this…? Is it still not working. It is still not working for me…any ETR…???

1 Like

@hangon create a batch file like the example I provided above. Then use windows task scheduler to schedule the batch file to start each morning (or to your liking).

@infinitezahoor we will receive an eta from @loginerror as soon as he has one. He seems to update us once a day or 2 days.

I’m facing a unique issue… when I run the command UiRobot with -file paramter from command prompt it’s working. But when I schedule this in the task scheduler… I’m getting the following issue.

System.Runtime.InteropServices.COMException (0x800706B2): No protocol sequences have been registered. (Exception from HRESULT: 0x800706B2)
at UiPath.Core.Session.StartSessionRpcServer(String accessSecurityDescriptor)
at UiPath.Core.Session.StartRPC(String accessSDDL)
at UiPath.Service.Impl.RpcServerController.StartServer(String rpcAccessSDDL)
at UiPath.Service.WindowsServiceManager.OnInitialize()
at UiPath.Service.ServiceManager.Initialize()

I have cleaned my UIPath Installation again and cleaned all the folders “Programdata” and .nuget and other directories… but still the same issue…

any idea ?

@hangon Was just able to run my automation in the same fashion. I’ve never seen that error, and I had no issues running mine. 2 questions, do you have the location of the robot defined correctly in the batch file? Also, do you have administrative privilege on the machine running the schedule?

It is still not working!! Please help me!

1 Like

Any update about this issue?, it is still not working.

1 Like

Hello my friend I have the same issue HRESULT: 0x800706B2)
with some robots who are executing from Windows Task Manager. This error is strange because is cutting the sql querys results of database and I haven´t to find a solution to resolve this.
With this error, the Event Viewer show me the next logs :