Scheduled process says Pending and never runs

Hello,

I’m new to Orchestrator and made a small tester process to get used to using the scheduler. This process will just bring up a message box, this process is set to unattended and I have checked to make sure I am the user and the correct machine is selected too. But the process is stuck on Pending, I have checked the UiPath Assistant and it doesn’t show the process running or pending. I have checked that the process is installed on the assistant. I know I am connected to Orchestrator as I have used other parts of it with no issues.
The Only difference is that I usually use my Personal Workspace Folder, however, I don’t have access to triggers in that folder, which is why I am using a created Tenant Folder, called Test. If it can be done in my Personal Folder that would be ideal, but the main focus is to get scheduling working.

Thanks in advance!

Hi @deguy42 ,

Could you please check if you have enabled non-prod or unattended license for your robot?

If you can share screenshots from license, robots, machine from tenant, user section from folder, would be more better.

Regards
Sonali

1 Like

Thanks for responding, here are some screenshots, let me know if these are what you were expecting:

Here is the Trigger:

This is the folder and I am set as the admin of this folder.

This is the License, I wasn’t sure if this is what you meant. I have the enterprise edition also.

This is the machine. ITVSDEV04 is the one where it should run on, and this option is selected in the actual trigger.

This is the Robot Section

This is the Users in the Tenant Folder:

Let me know if it isn’t clear enough or you need to see something more specific

Hi @deguy42

in addition to @sonaliaggarwal47 suggestion check if the user is assigned to robot in the orchestrator.

Tenant–>Users as below

Mine looks nearly the same with all the options ticked, but I don’t see the License Type panel.

Hi @deguy42,

Could you please click on see more under license screenshot(shared above) in Licenses and check its status(active or unlicensed)?

Regards
Sonali

did you log into UiPAth assistant with correct user account ?

do you see test process in Assistant as below

Here you go:

Yes I can, I can run it from the assistant with no issue, but not from orchestrator. Orchestrator just says pending on the process.

Hi @deguy42 ,

Looks like this is the problem. Your license is active on same machine ITSDEV04 with another userid(RPABOT) but now you are trying to do the process execution with another user(autogen) which is still unlicensed.

Did you try to execute process using the user/machine on which license is already active?

Regards
Sonali

2 Likes

I haven’t tried that, would this be done by running it from that user account? Or can I do it through my account? Could I even just move the license?

Hi @deguy42 ,

Yes, license can also be released by deactivating it in license tab and properly logging out from that machine.

Or you can assign that userid(rpabot) to the folder you are trying to execute your process from and delete the reference to another user.

Are you logged into the machine right now? if yes, which userid(rpabot or autogen)?

Regards
Sonali

I am currently logged in as the autogen, and when you say properly logging out from that machine, what do you mean?

@deguy42,

That means signing out by that user and not just disconnecting.

Please remove references for autogen in your folder and do stuff using rpabot or logout properly for rpabot, release the license assign it to autogen, check license status and then do execution.

Regards
Sonali

Hello,
I have encountered the same problem as you. Have you solved it now?
If you have solved this problem, can you share some experience and information to help me? I will be very grateful.

Hello,

Sorry for not updating, after speaking with UiPath, they pointed out the main issue is that the Attended and Unattended Robot are on the same machine. They must be on separate machines. Currently in the process of getting a second machine setup exclusively for the unattended bot. But that should fix the issue I was having.

Hope this helps!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.