Save polish characters to mysql table

Hello everybody,

I have to save polish characters to my database.
Instead of polish characters in my table i see ? characters.
The probleam persist only if i insert rows from robot! If i insert from MySQL Workbench, everything works well!

I tried several options for Charset/Collation setting in my database on table and column too.

But nothing :frowning:

Can you help me about this?
Thanks!

Hello @Arnold_Soos

Have you tried to log the queries?

Maybe you want to CONVERT the strings before. (the connector might be fine but the activity used to read your parameters applies the wrong enconding).

Thanks for your answer.

I have a simple activity, and a simple query. Look:

Capture

And my test query: "INSERT INTO my_table (title) VALUES ('śżnoci z ję')"
(same query works in mysql workbench directly)

That’s all.

@Arnold_Soos

Not sure the activity handles properly the encoding with your query string or when communicating with the server (I have a lot of issues of this kind with UiPath “official” python package, for example, and I need to implement a workaround routine each time).

Can you try to set explictly the charset in the connection (Configure Connection...), for example, with a connection string?

https://www.connectionstrings.com/mysql-connector-net-mysqlconnection/specifying-character-set/

Being explicit in the string encoding (or compensating an unwanted conversion by the UiPath activity with CONVERT or CAST) might also help

The setting about explicitly charset in the connection, now it’s ok, but same thing…

I will try the CONVERT or CAST one…

None of the above solution helped me. But thanks msan.

The solution was, that I select MySql Unicode Driver instead of ANSI Driver in ODBC Administrator for my connection.

1 Like