Save attachments from mail dont work anymore

Hello i have a function where i look for a specific mail and then saves all the attachments in a folder. This have worked before but suddenly without NO change in the workflow it dont work anymore. It only saves one image from the attachment instead of all 5 of them

Just give a try updating the activities you have in that project which you are using related to mail

Have already tried updating and also delete and add the activity again, but no luck

Its working for me, not sure about the issue.

I hope you have tried creating the new Sequence also, try forwarding the mail with the same attachments again and try saving the files again :slight_smile:

@langsem
check the path…

See if you are creating or deleting a target “folder” somehow in your execution steps.

tried both steps now, still it only manage to save one attachment

@langsem

If it used to work fine before and suddenly its not working now, then the problem might be with the name of the attachments in the input mail.

See if the names of that files in the input mails are unique.

If the names are same, then they will be overridden and at the end of the execution, only ONE file will be seen in the destination folder.

Also you can try to use message box to check the count of the attachments immediately after the GET MAILS is used.

Thanks and Regards,
@hacky

The attachments have unique names, but still it only gets one. This worked less than 40 minutes ago. The one file thats marked ( see image) its the only one getting saved in the folder, the rest of the images are not. The email has not changed either from the working period to now.

also getting this from the mail output

List(1) { MailMessage { AlternateViews=AlternateViewCollection(1) { AlternateView { BaseUri=null, ContentId=“a3c9e481-2be1-4d0a-81e6-83e615c43238”, ContentStream=MemoryStream { CanRead=true, CanRead=true, CanSeek=true, CanSeek=true, CanTimeout=false, CanWrite=true, CanWrite=true, Capacity=936, Length=936, Length=936, Position=0, Position=0, ReadTimeout=!, WriteTimeout=! }, ContentType=[text/html], LinkedResources=LinkedResourceCollection(0) { }, TransferEncoding=Base64 } }, Attachments=AttachmentCollection(1) { Attachment { ContentDisposition=[attachment], ContentId=“22d29a2c-b867-4289-994f-40c81ddda695”, ContentStream=MemoryStream { CanRead=true, CanRead=true, CanSeek=true, CanSeek=true, CanTimeout=false, CanWrite=true, CanWrite=true, Capacity=773, Length=773, Length=773, Position=0, Position=0, ReadTimeout=!, WriteTimeout=! }, ContentType=[application/octet-stream; name=ATT00001.png], Name=“ATT00001.png”, NameEncoding=null, TransferEncoding=Base64 } }, Bcc=MailAddressCollection(0) { }, Body=" \r\nSubject: 0000532103 \r\n\r\nHello,\r\n\r\nIDM (noreply@hurtigruta.no) has shared a document with you. \r\n\r\nMessage:\r\n\r\n\r\nRegards,\r\nInfor Document Management \r\n", BodyEncoding=ASCIIEncoding { BodyName=“us-ascii”, CodePage=20127, DecoderFallback=DecoderReplacementFallback { DefaultString="?", MaxCharCount=1, MaxCharCount=1 }, EncoderFallback=EncoderReplacementFallback { DefaultString="?", MaxCharCount=1, MaxCharCount=1 }, EncodingName=“US-ASCII”, HeaderName=“us-ascii”, IsBrowserDisplay=false, IsBrowserSave=false, IsMailNewsDisplay=true, IsMailNewsSave=true, IsReadOnly=true, IsSingleByte=true, IsSingleByte=true, WebName=“us-ascii”, WindowsCodePage=1252 }, BodyTransferEncoding=Unknown, CC=MailAddressCollection(0) { }, DeliveryNotificationOptions=None, From=[“noreply@hurtigruta.no” noreply@hurtigruta.no], Headers=HeaderCollection(7) { “Uid”, “Date”, “DateCreated”, “DateRecieved”, “HtmlBody”, “PlainText”, “Size” }, HeadersEncoding=null, IsBodyHtml=false, Priority=Normal, ReplyTo=null, ReplyToList=MailAddressCollection(0) { }, Sender=[“noreply@hurtigruta.no” noreply@hurtigruta.no], Subject=“0000532103”, SubjectEncoding=null, To=MailAddressCollection(1) { [“Alan Nikolai Langsem” alan.langsem@hurtigruta.no] } } }

@langsem

Try following:-

In the Save attachments activity:-

  1. Write the Mail Items in first field.
  2. Write the path using the attachment name (dynamically)…

s

Regards,
@hacky