Save As Window saving as xlsm

Hi all,
I’m having issues saving an excel file as a PDF, and am stumped as to why this is happening. I am typing the full file name with location into the “File Name:” box:

The log shows as:
location\Dashboard (note, NO .xlsm at the end)

And despite the above, when the process selects PDF and the filename without .xslm at the end, I get the following result:

Any thoughts?



I was trying to reproduce this and noticed there was a problem going from the Select Item to the Click Save. So I tried placing a TypeInto “[k(tab)]” before the Click Save and it worked.

Also, I’m not sure if using "PDF " will work if the item is “PDF (*.pdf)”. And, depending on the machine, sometimes the extensions are not included. You may need to explore other methods to select the item (for example, just a Click Text or you can also use Get Attribute of items attribute then filter it if it contains “PDF”)

Hopefully, that helps.


I will try the [k(tab)], thanks! If that doesn’t work I can try clicking/get attribute options too, it just seems like it is selecting PDF, as it shows it, but for whatever reason the Save As window doesn’t seem to realise it has.

The image is from when I made it on my local, the reason it says "PDF " below is, as you can see on the 2nd screenshot, the option on that VM is simply "PDF " (for some reason with a space after it?).