"Save as" after an extraction

Hi,

I know my question may be simple, but I am stuck on my first automation since a pretty long time.

I am doing a web automation which I am doing with the recorder.

The thing is that I am trying to extract an important amount of data from Microstrategy (a BI software) and converting them into an excel spreadsheet. The extraction itself works. However, the problem occurs after the extraction is done. Since the extraction takes a lot of time, this screens appears a lot of time (Processing Request) that can appear at least 15 times in a row. Processing Request. Since the extraction takes a lot of time, I tried to put some “Wait Image Vanish” and incorporated this image in each one. After around 3 minutes until my extraction is done and that I could click on “save as” as the option pop up (I wanted to put a second picture but since I’m a new user I cannot have 2 images in the same topic but could gladly send it). However, even if I recorded myself clicking on the arrow in order to click on “save as” to put my excel in the place that I want, it doesn’t work with or without the “Wait Image Vanish”. Furthermore, I even tried to use the F3 function to click exactly where I want, with or without anchor and now ran out of idea… I am a new user with Ui Path, this being my really first automation ever, I do not know if putting a timer saying to wait like 5 minutes to do the next step which would be to click on the arrow in order to save as could be a solution. Indeed, any kind of solution would be awesome to have.

Thank you really much for your time, it is really appreciated. Would really make my day.

Tommy


This is the second image :wink:

Hey @BOYER_Tommy, welcome to the community!

What is the error you are getting when you use “Wait Image Vanish”? Make sure the timeout attribute in your “wait image vanish” activity is set to a long enough amount of time to accommodate the long waiting time for your download.

Zev

Hi Zev,

I do not get any error for the “Wait Image Vanish”, it is because it is uploading the image more than 10 times in a row (like if I would refresh the page every time). It does wait until the image vanish, but create an identical many times in a row.

The thing is the process works fine for the “Wait Image Vanish”, but the automation stops when I want it to click on the arrow to process to my “save as”. The activity is only highlighted in yellow and it doesn’t continue my automation.

Here is a picture:

It can go until this step, but I do not know why it doesn’t work…

Thank you for your help, really appreciate it

Tommy

@BOYER_Tommy
Have a look here:

with get triggered by the status bar display status you can chain triggering other download progress steps e.g.

it is disiplayed and the Save as is to click
Or
reacting on … is downloaded message and close the bar

Hi ppr,

Thank you for your answer it was really clear. Here is what I could achieve to do:
I could create the “Get Attribute” Activity!
image

After that, I tried to go in UiExplorer

I do not have the same interface, but tried even if I didn’t have the same thing, but the result is the same: it just does not click on the arrow as desired.

I even tried to use some “Send hotkey” activities in order to do it manually, but didn’t work either.

Thank you for your time :slight_smile:

Tommy

@BOYER_Tommy
can you please help on following to get it more clear.
You are not using Internet Explorer, right? What are you using instead?

I am using Microsoft Edge, is it the cause of my problem?
I saw some videos on YouTube and noticed that on IE the selector can click directly one the arrow, the selector recognize the download bar, but in Edge, my selector seems to not see it; it selects the whole page:

It happened to me early in the process for some click I needed to do, but I could use the F3 function to select the right place without problem, but for the download bar, I do not know why it doesn’t want to work.

@BOYER_Tommy
I will try to have a look on it after my regular job and let you know my feedback.
But you have already ensured of having the edge extension properly installed, right?

Hi Peter,

Don’t worry, take your time :slight_smile:

image
Yes, my edge extension properly installed.

Feel free to answer whenever you can

Have a nice day

@BOYER_Tommy
I had done a first rnd round yesterday evening. It seems to me that some edge dialogs are not properly handled by the selector retrieval. But to bring it forward more analyzing is to do to come to a formal statement.

But in your case I do feel you can work with a work around. Downloads can be initiated with 3 options:

  • Click Link, init download by the promptbar (your screenshots)
  • click link, Strg + J Downloads Panel
  • Right click Link, Click on save target as

Last approach shows the common file dialog, that can be clicked, interacted … . So give a try on this for downloading a file

Hi Peter,

I tried the different options, when I do it, it works, but when it’s the time for the automation to do it, it doesn’t work. Indeed, I think it is because edge dialogs aren’t properly handled by the selector retrieval. It only works on the page itself and not on the download pannel.

I’ve tried to click the link and no result, I even tried to do it manually with my hotkey, it does work when I do it myself, but when UiPath does, it doesn’t.

The crtl+ J to open the download panel works, but the same problem occurs: it still think I am “under” the interface and working on the page itself. Tried with hotkeys too and still didn’t work.

I am not able to do a right click with UiPath… :open_mouth:

I am going to ask my manager if I can do the automations with IE instead, because I clearly see that with IE it would work easily. The hardest part of all my process is made, the only thing is that it doesn’t want to click on the download panel, but underneath it.

I went in the tools and didn’t see a IE UiPath extension, does it mean I do not need one for IE?

If it is not possible for me to use IE, I think the only thing I am going to do is that all the extraction will be made and the only manipulation that will need to be done is to place the extraction in the right file. I can even go write in the search bar where to put the automation, so the person that needs to place it has no problem to do it. That’s only if the IT doesn’t allow me to use IE to make my automations.

Thank you for all your help, the extraction itself is what was long and I am able to do it.

@BOYER_Tommy
thanks for your feedback. As mentioned by me right click save target as I do see the best chance to do it with Edge. I will habe a look on this in my evening and let you know my rnd result.

Internet Explorer does not need an UiPath extension . Making the download process more reliable the incorporated reaction on the promptbar as described in my link from above will help

Hi Peter,

Thank you really much for the advice about IE! I asked and I can use it :smiley:

I am now during the exact same process with IE and it works perfectly. I will be using IE for my web manipulation.

No idea why Edge is acting like that, but since it works with IE, I’ll make it that way without any problems.

Again, a great thank you Peter!