Save a PDF generated from a website but save icon disappears


#1

Attached is a image of the PDF that is generated from a workflow I’m working on. It’s generated by SunNet Consulting’s TOA application (http://www.sncsw.com/)

I generated the workflow by Recording my steps… and it works great when I re-run the steps up to the point where I want to save the generated pages as PDF.

When I recorded it, I clicked on the Save icon… but when I run the script, it throws an error:

Attach Window ‘ReadingUn Dialog’ : Cannot find the UI element corresponding to this selector:

I’m guessing because it’s not moving the mouse to hover in the same location to “SEE” the save icon? Help?


#2

Hi,

It’s clearly mentioned that can’t find ui element which means selectors are dynamic.
Please try to get reliable selector using UiExplorer or by using wild card *,?

PS: To save you could have used "Send Hotkey " activity Ctl+S to save pdf rather than clicking on icon.


#3

Hmmmm… I’ll have to look at the UiExplorer… just saw it.

I tried using Ctrl+S … but got another error:

due to an ElementNotSet error?

Thanks for the reply!


#4

Please indicate pdf screen where you wants to send hotkey.


#5

GENIUS!!! Thanks you so much. Would have never figured that out. I’ll have to be on the lookout for future blue hints like that. Yahoooooo!