SAP Selectors - Problems recognizing fields on Windows Server

Hello everyone,

I had already opened a similar thread before. I had problems in SAP to clearly recognize the SAP fields. I was advised to set the scaling to 100%. This worked fine.

The current problem is slightly different from the previous ones. I would like to run an application that was created locally on a server where the unattended robot is located. Unfortunately, the robot does not find the defined fields, although the scaling is also set to 100%.

After consultation with our administration, Per-Monitor and Per-Monitor (V2) DPI Awareness is not supported by Windows Server.

Therefore, all screenshots and selectors that have already been saved and published locally must be recreated on the server and only created with the help of F2.

I tried to “trick” and checked the selector names using the UI Explorer locally, and replaced the selectors on the server e.g.

Server: <sap_id=‘usr’ />
Local: <sap_id=‘usr/pwdRSYST-BCODE’ />

Unfortunately this didn’t work.

Does it mean that every application that is built locally must always be fixed on the server and vice versa? Does anyone know how I can work around this problem?

Thanks in advance.

Hi @dziekanski

Can you share a real screenshot and example of selector on Server and Local?

Selectors are technical ids, which has nothing to do with DPI

Best regards, Lev

1 Like

Hello Lev,

I’m sorry for the late reply and many thanks for your answer. I will try to explain the situation using the screenshots:
Local Settings:

I have no way of specifying the scaling on the server. The scaling is taken from my server binding settings
Server Settings:

grafik

As for the process itself, I’m building an application locally. the screenshots are also shot locally. our unattended robot is on a server.

A finished application is passed to Orchestrator.

grafik

I then log on to the server and execute the transaction there. The problem is that in some cases, the robot doesn’t find the fields even though the fields are the same´

grafik

grafik

in the local version the robot finds the field, in the server version it doesn’t
grafik

for further questions feel free to contact me. Thanks in advance.