SAP BAPI Package - SAProuter Parameter Missing

sap
activities
i_considering

#1

Hello UiPath Team,

today I tried your Manage Packages functionalitiy and I found a package called UiPath.SAP.BAPI.Activities.

UiPathBAPIPackage001

After the successful installation of this package I wanted to try it, but I can’t. To connect my SAP backend system I need the SAProuter parameter but your package doesn’t offer the possibility to set it.

But in some cases is this parameter necessary.

UiPathBAPIPackage003

Could it be possible that you add this connection parameter to your next release of your package? That would be great.

This parameter is exactly the same as Language, User, Client, etc.

UiPathBAPIPackage004

Thanks in advance.

Best regards
Stefan


#2

Hi Stefan,

Thanks for your feedback. We will consider adding this parameter to the activity pack. Until we do so, you can add it by including the below key in appSettings in the UiPath.Studio.exe.config (for Studio) and UiPath.Executor.exe.config (for Robot). These config files are found in your UiPath installation folder.

<appSettings>
    <add key="SAP.BAPI.SAPRouter" value="your_saprouter_string"/>
</appSettings>

You can also use this mechanism to configure other RfcConfigParameters of the SAP .NET Connector such as LogonGroup, CodePage etc. The key is specified as SAP.BAPI.<parameter_name>.

Hope this helps.

Regards,
Bhushan


#3

Hello Bhushan,
thank you very much for your message. And also thank you for effort to implement this field and the tip to set SAProuter string, that is good to know. :slightly_smiling_face:
Best regards
Stefan