Running unattended bot on VM

Hello,

I am running an unattended bot on VM. I logged in to the user the robot is using but I seem to be logged in on a different session. When I checked task manager, I see 2 users for the credentials logged in, one with the application we automated. The only way I can logged in to the session it used is when I stopped the robot from running. My question is, how can I have the same session with the bot?

Troubleshooting will be difficult if I can’t login with the session it is using.

Troubleshooting I did:
changed login to console to true but I am encountering the terminated login error when it is set to true.

Any suggestion? We are still using 2016 version but we are planning to migrate to 2019, just waiting for the server machine we will use for parallel upgrade.

From my understanding of what your problem is… while the robot is using a logon session, you can’t log into that session, until it logs out.

I believe this is because your Server admins enabled a feature that allows Simultaneous Logon sessions. This should not be enabled. This could have been enabled by mistake when your Server admin was trying to support High Density robots. However, all you need for High Density is Logontoconsole=“false” and the Remote Licensing feature enabled, which allows for more than two users logged in to the server at a time.

for more information, there are some online resources such as this one: https://social.technet.microsoft.com/Forums/en-US/c52b6da7-cdf2-4e1f-95d1-6471c6f2f6b0/easiest-way-to-enable-more-than-2-concurrent-rdp-sessions-on-windows-server-2016?forum=winserverTS

I hope this helps.

Regards.

2 Likes

also, disable the Simultaneous Logons option, like I mentioned.

Thank you! This fixed the issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.