Running the bot through batch file , old bot xaml executing although giving another workflow file

Can someone help me with this? I am changing the main .xaml path … I mean mentioning the different Xaml and another project. but it taking the previous one only on bot running … The irrespective batch file path,
Another thing noticed If UIrobot tray is already opened then Process is not running . can you please help me on this

may i know how its mentioned now with an example
that could help us to validate on this buddy

and for this

i hope it wont be actually, robot tray being on is fine and it wont interrupt the process getting executed
that is if any process is ran from robot tray and if we try to run our process it wont, because the robot is busy in executing that process

Cheers @Vijay_RPA

1 Like

For the First one …
I just want to run the bot through Batch file and created it by giving UiRobot path and Main.Xaml path for respective process … and then I just want run another process and removed first one gave another process Xaml . When i tried to run the Bot it is taking the first process main.Xaml only . @Palaniyappan

And then I removed Main.xaml path in batch file script … When i tried to run the bot It is automatically taking first process Xaml on bot running (Not into Batchfile)

as you said but
here the xaml file path looks same

was the file saved after changing the filepath
Cheers @Vijay_RPA

Yes removed In batch file to test … After Removing also It taking first Xaml (With Empty path in Batch file )…
I tried to execute in CMD same thing happening :frowning: @Palaniyappan

you mean like you have removed the xaml file path and kept only the uipath executor file path alone
like this

Cheers @Vijay_RPA

Yes … Although its is running the Previous Path file (First one) … Even i tried excute the command by using different process Xaml in cmd … it is executing old one only @Palaniyappan

Hi @Vijay_RPA ,

Go to studio and select your xaml and right click on it ,set is as main.
Then try with the bot .

Hi Rajesh, Got Your Point But i am just going thorough different projects and Different Main.xaml . I had two project Like A and B . First I executed Main.XAML in A and then Removed that then Tried to Execute B … But It is execute A only … Although I removed Entire Path Of Main XAML still is taking A only .

Please add main.xaml as its default xaml and give one message box(activity) there and change it according to my screenshot.
Try it first with debugging mode if it works then run with bot.
I hope both the projects name are different.

Yes Different Paths Too … Different Folders too

Will you able to provide project structure screenshot?

Sure But Can you observe screenshot I am not giving any main Nut it executing Old one through the batch file

And this what happening

Vijay, I suspect as below:
Project 1:
Main.xaml_Set as Main

Main.xaml-Set as main

You removed Main.xaml from project 1 but still Main.xaml in project 2 as set as main ,so running the Main.xaml from project 2.
If my expectectation is correct ,select the xaml which you want to run from project 2 and set it as main.

Yep will try now

The version I’m using is 2020.10.6 and UiRobot.exe is in a different folder not Local App Data. Mine is at C:\Program Files (x86)\UiPath\Studio\UiRobot.exe and it doesn’t work.

As far as I know this version uses UiPath Assistant instead of UiPath Robot, how can I execute in bat with this version.

1 Like