Running process on different PCs under machine template - host identity

I’m trying to run an unattended process on multiple different PCs in orchestrator. I’m using a robot account with the host name of PC 1, and running a job on PC 1 works but running a job on other PCs just shows ‘Pending’. I noticed the host identity of each process is the hostname of PC 1 regardless of the pc I run it on. I tried changing the hostname of the robot account to PC 2 and running a job on PC 2, but it still didn’t work, and this time it didn’t work on PC 1. I notice when I create a job the dropdown menu for hostname shows ‘[machine name] - [hostname]’ for PC 1, but only shows ‘[machine name]’ for the other PCs.

Hi @jc.rds ,
Each machine needs a robot installed on it.
The orchestrator should have the sufficient number of licenses equal to the robots you are connecting to it.
To run a process on a machine. Robot should be fine.
You can install the UiPath robot and get the machine key and connect to Orchestrator.
Once connected, you can schedule the process at particular time, so that one process can run in different machines
Reagrds,
LNV

@jc.rds

  1. How many licenses are assigned to the machine? Number of running jobs is in direct relation with number of unattended licneses given to the machine
  2. Are both the pc’s connected if yes then they would work…only thing is if no licenses it would work one after the other as there is only one license

Cheers

There’s only one license associated with the machine template as far as I’m aware. But I’m not trying to run the jobs concurrently; even when I only queue a single job it does not move past pending.

Both PCs show as connected and licensed in Assistant and appear as selections in orchestrator.

I haven’t found a way to create additional robots, only robot accounts through UiPath admin which don’t seem to be visible/selectable elsewhere. If UiPath robot is the same thing as UiPath assistant then I have already connected the PCs to orchestrator via machine key.

@jc.rds

Is the machine showing available?and what license are you on?

Cheers

I’m using the pro (trial) license. I’m not sure how to check if a machine is available, but each connection through Assistant shows as connected and licensed, and all hosts are able to be selected when starting a job.