Running Macro in Citrix

Hi all,

I am trying to run macros in excel in Citrix environment, I have a bot user (different from my admin user on my laptop), and every time i get to running a macro during a process I get this:


I had the same problem when I ran the process in my laptop but managed to fix it by going in registry editor and disabling a variable called “blockcontentexecutionfrominternet”.

I tried going on excel in my virtual machine, enabling all macros, making the files trusted documents, but doesnt work

Does you have an idea on how to fix this?

Thank you!

Hi @dcandido,

Is macro working fine when you run it in excel i.e without using uipath?

Hi @veerlapativenkatesh,

yes, works fine, so Im sure the macros are ok…


Could you please confirm your marco name again.

Hi @dcandido
For what are you using this macro… is it to remove duplicates rows in a column of a datatable

Hi guys,

macro name is correct and code as well, I have been using it for some time already. I am sure this is somehow related to excel security or windows admin rights somehow. This is not just happening on this specific macro but on all processes with macros that im running… I can run the processes in my laptop where im admin, but not in the virtual desktop of citrix, where im not admin.

kindly check whether the macro is enabled in that excel

and also the file extension be like .xlsm

and make sure that the EXECUTE MACRO is placed inside the EXCEL APPLICATION SCOPE activity

Cheers @dcandido